Virtual Happy Hour this month, Jun 28, we'll be getting a sneak preview at our soon to launch SaaS CMS!

Try our conversational search powered by Generative AI!

Upgrade fails on disable/update add-ons



Im trying to upgrade to EPiServer 7.5 from EPiServer 7. I have followed the upgrade guide and evrything has went well, until step 13 "select Upgrade/Disable Add-ons after Product Upgrade" in EPiServer Deployment Center.

When i try to complete the step i end up with this error:

Started a transacted install

An unhandled error has occured:
Cannot bind argument to parameter 'Path' because it is null.
When executing

At C:\Program Files\EPiServer\CMS\7.5.394.2\Upgrade\System Scripts\Upgrade Add-
On Packages.ps1:104 char:14
+ if (Test-Path <<<< $packagesToInstallPath)

An error has occured and the transaction will be rolled back

At C:\Program Files\EPiServer\CMS\7.5.394.2\Upgrade\System Scripts\Upgrade Add-On Packages.ps1:104 char:14
+ if (Test-Path <<<< $packagesToInstallPath)
System.Management.Automation.ParentContainsErrorRecordException: Cannot bind argument to parameter 'Path' because it is null.


Is there anybody that have a clue how to soleve this or have any suggestions of what the problem is about?

Feb 27, 2014 11:55

Please check the section episerver.framework/appData in your web.config/EPiServerFramework.config. The value of basePath attribute should contain a path to your appdata folder where your blobs (VPP files in previous epi versions) and add-on repositories are deployed. You can see it as former VPP folder of your site. This path can be relative.


<appData basePath="C:\EPiServer\VPP\YourSite" />


<appData basePath="..\appdata" />


Feb 27, 2014 13:19

A bit of speculation on what maybe could cause the problem if the above is not the case:

Is it possible that there is a mismatch of the EPiServer.Install.Common.1 assembly in the GAC or even wrong version of the EPiServer Shared msi installed?

Feb 27, 2014 13:27

Thanks for the quick answers. I think that the appData path is correct. But will expriment with both your hints and tell you the outcome.

Feb 27, 2014 15:36

I have now tried the appData path with both relative and absolute path. Non of them changed the error message. I also uninstalled all EpiServer programs, and reinstalled the latest Deployment Center. But still have the same error.


I can't figure out what the error message want me to do, and how i fix it. So any help is more then welcome.

Feb 27, 2014 16:42

Could you check the version of EPiServer.Install.Common.1 assembly in the GAC?

Feb 27, 2014 16:43

I have the version 1.1.1997.0

Feb 28, 2014 8:49

We have exactly the same issue. How did you solve the problem?

May 15, 2014 16:20

We have not solved it yet. Please tell me if you hav any idea or get any help about how to solve it.

May 15, 2014 17:49
Edited, May 15, 2014 17:49
May 15, 2014 17:50

It's hard to tell exactly what exactly has gone wrong based on the above. Lack of a basePath value in the episerver.framework/appData web.config section really seemed like the most probable cause.

I would recommend that you contact EPiServer Support for more in-depth troubleshooting of this problem.

May 15, 2014 18:25

I debugged the upgrade script and assemblies and found that the configuration file (web.config) didn't contain <sites> node anymore.

After adding the node back, the Add-ons upgrade completed successfully.

Seems like the steps described in Upgrading-to-EPiServer-75-CMS are not in the correct order.

May 16, 2014 14:27

I am having this issue as well, if anyone has found a resolution.  I have a sites node.

Jun 12, 2014 22:16
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.