Try our conversational search powered by Generative AI!

Localized Editor




I'm trying to get a localized editor going, but it doesn't seem to work.

I've tried following this blogpost, but I get no result going. I've also registered a provider as seen in this XML-segment:

  <localization fallbackBehavior="Echo, MissingMessage, FallbackCulture" fallbackCulture="no">
      <add virtualPath="~/Resources/LanguageFiles" name="languageFiles" type="EPiServer.Framework.Localization.XmlResources.FileXmlLocalizationProvider, EPiServer.Framework" />

This is my language file:

<language name="Norsk" id="no">
    <pagetype name="ActivityPage">
      <description>Inneholder informasjon om en aktivitet.</description>

Is there any documentation around this?

// Anders

Mar 11, 2014 7:57

The xml structure is different for 7.5. See Linus blogpost for more info:

Mar 11, 2014 8:13

Thanks, Per!

That worked beautifully!

EDIT: One thing I noticed is that «name» and «description» of the page type didn't work at all. It uses the name of the class and it says that no description is available.

Edited, Mar 11, 2014 9:39

I followed Linus' post and the «name» and «description» doesn't work for me. This is my XML:

<language name="Norsk" id="no">
  <!-- Page Types -->
      <description>Inneholder informasjon om en aktivitet.</description>

I also have properties inside the different page type elements and those works pretty good.

What am I doing wrong?

Mar 12, 2014 7:51

The xml looks correct. Could it be a fallback issue? Do you have norwegian set as the current episerver user's personal languge?

Mar 12, 2014 9:23

Thanks, now it works. I thought it was based on which language you were editing in, not the user's current language. It all makes sense. Thanks for your quick reply, Per Magne.

Mar 12, 2014 9:39
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.