Virtual Happy Hour this month, Jun 28, we'll be getting a sneak preview at our soon to launch SaaS CMS!

Try our conversational search powered by Generative AI!

MVC 2.0 Application is compatiable with EPI Server 7.5 CMS?

Vote:
 
Hi All, We are planning to purchase EpiServer 7.5 CMS and for that we needed some information. We understand that we need MVC 4.0 framework installed. But does this mean that EPiServer 7.5 CMS works only with application built with Mvc 4.0 and above. We have an MVC 2.0 application with views as ASPX and not Razor (Razor views were released post MVC 3.0). So does this means we need to migrate to MVC 4.0? Thanks and Regards, Manu.
#90505
Sep 11, 2014 4:59
Vote:
 

I do not know about mvc 2 but you can use aspx-views in mvc 4 also

#90509
Sep 11, 2014 7:55
Vote:
 
Thanks Henrik. My question is that do we need to have our application migrated to MVC 4.0 version to use EPI Server CMS 7.5?
#90511
Sep 11, 2014 8:51
Vote:
 

I guess it's dependant on Mvc 4.0 as EPiServer Framework contains reference to Microsoft.AspNet.Mvc (>= 4.0.20710) package.

#90517
Sep 11, 2014 9:46
Vote:
 
Thanks for the reply Valdis.
#90549
Sep 12, 2014 4:32
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.