Try our conversational search powered by Generative AI!

Another Indexing Service/Search question


Looks like a lot of people have had issues setting up the indexing service - just googling it returns lots of results.

We have two load-balanced servers, and I've finally got search working (sort of), by following this blog post (thanks Henrik):

Just a couple of peculiarities:

1. The indexing service seems very busy. If someone is on the site, it's constantly updating the index. Despite this, it can take a couple of hours for new search terms to work. For example, if I add a page, publish it, it won't pop up in search results for quite a while.

2. The 'secret' manual reindexing page (https://site/episerver/cms/admin/IndexContent.aspx) generates a server error:

SearchSettings: Could not reset index '' for service uri ''. Message: The remote server returned an error: (500) Internal Server Error.   at System.Net.HttpWebRequest.GetResponse()
   at EPiServer.Search.RequestHandler.MakeHttpRequest(String url, NamedIndexingServiceElement namedIndexingServiceElement, String method, Stream postData, Action`1 responseHandler)
   at EPiServer.Search.RequestHandler.ResetIndex(String namedIndexingService, String namedIndex)

I've tried changing the name of the index, defaultIndex etc. Not sure if I've configured that correctly.

Any ideas? Thanks

Nov 13, 2015 0:36


I think that you could turn on detailed log4net logging for search index. This should give you more information about exception:

<?xml version="1.0" encoding="utf-8"?>
<!-- ...  -->
    <logger name="EPiServer.Search.IndexingService.IndexingService">
      <level value="DEBUG" />
<!-- ...  -->

You could also verify if Application Pool has access to index direcotry.

And if you are using SSL, then check if web.config binding configuration for “IndexingServiceCustomBinding” are properly configured.

Nov 13, 2015 7:30

Thanks Grzegorz,

I'm still getting the error, but interestingly if I click the 'Start Indexing' button multiple times, it actually does start a reindex! This behaviour was also reported here:

"To really start the reindexing I had to click the “Start Indexing” button multiple times. The request should start to process for a longer time. If the request finishes immediately, try click the button again."

Anyway, I think I can live with how it's setup now,


Nov 16, 2015 4:04
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.