Try our conversational search powered by Generative AI!

Unable to create page and blocks


Hi, I upgraded my site from episerver 8.8 to episerver 9.3.1 and now i am start having problem not able to see ant blocktypes to create block and no pagetypes to  create pages. 

This the error i am getting Value cannot be null. Parameter name: virtualPath & dojo _317 error

here is the link of my browser console.log and network.

Before the upgarde everything was working fine. I tried everything but unsuccessfull so need some help here.

Nov 10, 2015 11:08

Has the site been upgraded from an older version of Episerver? I was upgrading a site from 8 to 9 the other day and noticed it had a legacy VPP reference in the <episerver.framework> element that was causing errors (in my case the entire site didn't start).

There were a number of breaking changes in 9 so it may be worth checking the documentation against your solution:


Nov 10, 2015 21:50


We are experiencing the same issue. We hade the site in EPi8, and upgraded just recently to 9.3.3. We can create blocks, but only in the global catalog. If we click on the "Create block"-link inside any ContentArea, we get this exception nested inside the DOJO-errors.

I've checked the <episerver.framework>-references and they are all fine.

I am sure it's some sort of configuration issue that is leftover. Or in worst case, old references in the database.

Did you ever find a solution for this?

Best Regards Magnus

Dec 03, 2015 14:34

I just wanted to drop by and tell you that I found the culprit in our case:
It was far tricky, and I needed to reflect EPiServers dlls to solve it.

It was one page type that defined an empty thumbnail-attribute:

Like so, this is baaaaad:

This worked in EPiServer 8.x and must have changed behavior after that (9.0-9.3.3).

I suggested to the support that they should add some sort of safeguard in the lookup methods inside EPiServer.Cms.Shell.UI.Rest.ContentTypeStore. Where this weakness exists.

Hope it helps someone else.

Dec 04, 2015 16:32
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.