Try our conversational search powered by Generative AI!

Missing media and block folders



So all of a sudden, the media folder tree and the block folder tree doesn't show up in the widget.

However, it does show up when i try inserting an image:

Where can I begin to debug this? I can't find any errors anywhere.

Jun 05, 2015 15:38


First you could check access rights in Admin mode. Maybe there is some wrong setup. Go to: Admin->Set access rights -> "For all sites"

Then you could turn on JavaScript debug mode in EPiSever.Framework configuration section (<clientResources debug="true" />). After refreshing the page there should be something in the console.


    <clientResources debug="true" />

    <appData basePath="App_Data" />
    <scanAssembly forceBinFolderScan="true" />
    <virtualRoles addClaims="true">
        <add name="Administrators" type="EPiServer.Security.WindowsAdministratorsRole, EPiServer.Framework" />
        <add name="Everyone" type="EPiServer.Security.EveryoneRole, EPiServer.Framework" />
        <add name="Authenticated" type="EPiServer.Security.AuthenticatedRole, EPiServer.Framework" />
        <add name="Anonymous" type="EPiServer.Security.AnonymousRole, EPiServer.Framework" />
        <add name="CmsAdmins" type="EPiServer.Security.MappedRole, EPiServer.Framework" roles="WebAdmins, Administrators" mode="Any" />
        <add name="CmsEditors" type="EPiServer.Security.MappedRole, EPiServer.Framework" roles="WebEditors" mode="Any" />
        <add name="Creator" type="EPiServer.Security.CreatorRole, EPiServer" />
        <add name="PackagingAdmins" type="EPiServer.Security.MappedRole, EPiServer.Framework" roles="WebAdmins, Administrators" mode="Any" />
      <clear />
      <add name="ProtectedModules" virtualPath="~/EPiServer/" physicalPath="Modules\_Protected" type="EPiServer.Web.Hosting.VirtualPathNonUnifiedProvider, EPiServer.Framework" />
    <geolocation defaultProvider="maxmind">
        <add name="maxmind" type="EPiServer.Personalization.Providers.MaxMind.GeolocationProvider, EPiServer.ApplicationModules" databaseFileName="App_Data\GeoLiteCity.dat" />
    <localization fallbackBehavior="Echo, MissingMessage, FallbackCulture" fallbackCulture="en">
        <add virtualPath="~/Resources/LanguageFiles" name="languageFiles" type="EPiServer.Framework.Localization.XmlResources.FileXmlLocalizationProvider, EPiServer.Framework" />
Jun 05, 2015 23:41

Thank you for your answer Grzegorz. I found everything was OK with the permissions for the folders.

The javascript console gives no error when i view the block folders, however it does give an error when i insert an image.

ContentNotFoundException: Content with id 1527 was not found

I tried with an old database where the folders were still working, and after the job "Remove abandoned BLOBs" ran, the folders were gone. I think the issue is with this job.

Any idea how I can fix this?

Jun 08, 2015 16:41


Do you have full stack trace for this exception (you should find it in Chrome network response details, somewhere in your application logs or in the Windows Event Viewer)

This will be very helpful.

Jun 08, 2015 22:32

<title>Content with id 1527 was not found</title>
<meta name="viewport" content="width=device-width" />
body {font-family:"Verdana";font-weight:normal;font-size: .7em;color:black;}
p {font-family:"Verdana";font-weight:normal;color:black;margin-top: -5px}
b {font-family:"Verdana";font-weight:bold;color:black;margin-top: -5px}
H1 { font-family:"Verdana";font-weight:normal;font-size:18pt;color:red }
H2 { font-family:"Verdana";font-weight:normal;font-size:14pt;color:maroon }
pre {font-family:"Consolas","Lucida Console",Monospace;font-size:11pt;margin:0;padding:0.5em;line-height:14pt}
.marker {font-weight: bold; color: black;text-decoration: none;}
.version {color: gray;}
.error {margin-bottom: 10px;}
.expandable { text-decoration:underline; font-weight:bold; color:navy; cursor:hand; }
@media screen and (max-width: 639px) {
pre { width: 440px; overflow: auto; white-space: pre-wrap; word-wrap: break-word; }
@media screen and (max-width: 479px) {
pre { width: 280px; }

<body bgcolor="white">

<span><H1>Server Error in '/' Application.<hr width=100% size=1 color=silver></H1>

<h2> <i>Content with id 1527 was not found</i> </h2></span>

<font face="Arial, Helvetica, Geneva, SunSans-Regular, sans-serif ">

<b> Description: </b>An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.


<b> Exception Details: </b>EPiServer.Core.ContentNotFoundException: Content with id 1527 was not found<br><br>

<b>Source Error:</b> <br><br>

<table width=100% bgcolor="#ffffcc">

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.</code>



<b>Stack Trace:</b> <br><br>

<table width=100% bgcolor="#ffffcc">

[ContentNotFoundException: Content with id 1527 was not found]
EPiServer.DataFactory.Get(ContentReference contentLink, ILanguageSelector languageSelector) +424
EPiServer.DataFactory.Get(ContentReference contentLink) +193
EPiServer.Cms.Shell.UI.Rest.ContentQuery.GetChildrenQuery.GetContent(ContentQueryParameters parameters) +211
EPiServer.Cms.Shell.UI.Rest.ContentQuery.ContentQueryBase.ExecuteQuery(IQueryParameters parameters) +58
EPiServer.Cms.Shell.UI.Rest.ContentStructureStore.Get(ContentReference id, String query, ContentReference referenceId, String[] typeIdentifiers, Nullable`1 allLanguages, IEnumerable`1 sortColumns, ItemRange range) +389
lambda_method(Closure , ControllerBase , Object[] ) +422
System.Web.Mvc.ReflectedActionDescriptor.Execute(ControllerContext controllerContext, IDictionary`2 parameters) +258
System.Web.Mvc.ControllerActionInvoker.InvokeActionMethod(ControllerContext controllerContext, ActionDescriptor actionDescriptor, IDictionary`2 parameters) +39
System.Web.Mvc.&lt;&gt;c__DisplayClass13.&lt;InvokeActionMethodWithFilters&gt;b__10() +124
System.Web.Mvc.ControllerActionInvoker.InvokeActionMethodFilter(IActionFilter filter, ActionExecutingContext preContext, Func`1 continuation) +800086
System.Web.Mvc.ControllerActionInvoker.InvokeActionMethodFilter(IActionFilter filter, ActionExecutingContext preContext, Func`1 continuation) +800086
System.Web.Mvc.ControllerActionInvoker.InvokeActionMethodWithFilters(ControllerContext controllerContext, IList`1 filters, ActionDescriptor actionDescriptor, IDictionary`2 parameters) +307
System.Web.Mvc.ControllerActionInvoker.InvokeAction(ControllerContext controllerContext, String actionName) +800152
EPiServer.Shell.Services.Rest.RestControllerBase.ExecuteCore() +301
System.Web.Mvc.ControllerBase.Execute(RequestContext requestContext) +332
EPiServer.Shell.Services.Rest.RestHttpHandler.ProcessRequest(HttpContextBase httpContext) +274
System.Web.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +913
System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean&amp; completedSynchronously) +165



<hr width=100% size=1 color=silver>

<b>Version Information:</b>&nbsp;Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.34248



Jun 09, 2015 9:36


From CMS/Admin in ADmin Search Users and Groups, Select your account as admin and Edit the User, In Display Options tab, Click Reset Views and Save.
It may help you.


Jun 09, 2015 11:13

Thank you for your input K.

Tried it and still no luck.

There should have been a way to recreate the folders or something, because right now the editors can't even create new ones.

Jun 09, 2015 12:31

You may find some clues ... 
Any suspicious entry in Trash?
Use Admin/Config/Tool Settings/Change Log to see history what Editors have been doing from the time when application was working last time.


Edited, Jun 09, 2015 12:37

Trash appears empty, however I get the same error in console as i pasted earlier when i view trash bin.

No editors have deleted anything in the period this happened. It happened around the same time on 4 different environments.

I think the "Remove abandoned BLOBS" job deleted something it shouldn't have. I took an old working database on my local environment. While I was browsing, the shceduled jobs started, and afterwards, no block folders anymore (or media folders).

This job is set to active scheduled job.

Jun 09, 2015 13:02

In theory Remove abandoned BLOBS removes blobs only permanently but not folders. Folders are based on EPiServer.Core.ContentFolder
It is good that you can replicate issue in your enviornment so that can be fixed also, If you take the old copy of DB and see logs and Trash also that may help


Jun 09, 2015 13:18


Same thing happend to me. I have a multisite setup with multiple languages. The block folder structure was just working in one of the sites.

I went into admin and uncheck the "use site-specific assests". Go back to edit mode on that site and it now it is working. You now can turn "use site-specific assests" on again in admin and it still works for some strange reason.

Regards Øyvind

Jun 15, 2015 13:58

It worked!

What a weird bug. Episerver should fix this.

Big thanks Øyvind!

Jun 15, 2015 15:28
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.