Try our conversational search powered by Generative AI!

Page search configuration



On my local project and a deployed test version of the same project I can search for pages in the CMS tree and results are found based on the name of the page (as I would expect). A client has the project set up on their environment and the search is not returning any results based on page name but is returning results based on the ID of the page (our local does not return any results based on page ID).

Our local project and the client project should be the same so I'm a bit stumped as to why this would be the case. Is there anywhere to control this that may be different between the projects?

I've checked the config files and I can't find anything obvious. I've also asked the client to confirm that the indexing service is running and it appears ok (they can access the service URL correctly) and they have refreshed the index using cms/CMS/Admin/indexcontent.aspx.

Any thoughts gratefully recieved as always.



Jun 16, 2015 15:22


You could check few things:

1) Check the web.config section if it's configured correctly

< active="true">
<namedIndexingServices defaultService="serviceName">
<add name="serviceName" baseUri="http://localhost/IndexingService/IndexingService.svc" accessKey="local" />
<searchResultFilter defaultInclude="true">
<providers />

2) Check if the address http://localhost/IndexingService/IndexingService.svc will return "endpoint not found" (then it's ok).

3) You could check the EPiServer logs.

You could turn on logging:

<logger name="EPiServer.Search.IndexingService.IndexingService">
<level value="Debug" />
<appender-ref ref="IndexingServiceAppender" />

4) Could be a problem with SSL.

Jun 16, 2015 15:40

Hi Grzegorz,

Thanks for that. 1 and 2 are fine, I'll ask the client to turn on logging and if they are using SSL

The strange thing is that results are being returned which suggests it's configured correctly however it seems to only search against page ID rather than page name where ours does the reverse.



Jun 16, 2015 17:04


I have one more suggesion. You could also check if your Application Pool user have access rights to folder where index is stored (e.g. C:\indexes\EPiServerSearchIndex).

<add name="local" description="local" allowLocal="true" readonly="false" />
<namedIndexes defaultIndex="default">
<add name="default" directoryPath="C:\indexes\EPiServerSearchIndex" readonly="false" />

Jun 17, 2015 9:10

Thanks Grzegorz,

I think the last suggestion would be ok as the index is on the same file share as the assets which are used on the site (and the site has no problems accessing assets). This would still not explain why results are actually being returned but when searching by page ID rather than page name.


Jun 17, 2015 16:04

I've been having this same issue for quite awhile and have been unable to figure it out myself.  Same issue, searching by ID seems to work, but by name for any type of object does not work and returns no results.

Hopefully someone can finally answer this and help all of us out who wish to use the search feature within the CMS

Jun 17, 2015 18:41

Hi Mike,

Did you find a solution to this? Our client is still seeing the issue.



Aug 27, 2015 15:10
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.