Try our conversational search powered by Generative AI!

Installing CMS, package restore fail


Hello! I am following the guide here:
But for some reason the packages (mvc and episerver) are not restored when I build the solution - maybe because package.config or some entries in the project file are missing..?
Anyhow, the build fails with assembly/reference not found.
Anyone has an idea what is going on?
NB. The VS option for automatically restoring packages is on.
Best regards,

Edited, Apr 17, 2018 14:54

Have you made sure you either have the nuget feed in VS or have a nuget.config file in your web application with

<?xml version="1.0"?>
    <add key="NuGet offical package source" value="" />
    <add key="Episerver Nuget Feed" value="" />
Apr 17, 2018 15:01

Hi Soren,

Apologies if this is too obvious but have you set up the Episerver nuget feed in your package sources in Visual Studio?

Apr 17, 2018 15:03

Yes, I have set up the feed! I believe all the settings are 'correct'.. but I don't know if there could be an override option somewhere, like 'Ignore all other settings and don't restore'..:)
Best regards,

Apr 18, 2018 13:08

Have you tried just right clicking the solution in VS and selecting "Restore Nuget Packages"?

Apr 18, 2018 13:15

Hi Scott, that option seems not to be available in VSC 2015/2017..

Apr 19, 2018 12:30


I have it showing in Visual Studio 2017, I think the only reason it wouldn't be showing is if you havn't got nuget configured correct for your project if it isn't.

Apr 19, 2018 12:33

Visual Studio Community (Edition)..:)
I have configured the sources correctly, and I don't believe I have 'fiddled' in any 'special' way with other VS settings.

Apr 19, 2018 12:55

As I understand, for package restore to work, there should be either a file 'packages.config' or some PackageReference XML-elements in the csproj file. But neither of those are in the solution which is generated by the Episerver VS extension/template.

Apr 19, 2018 13:49

I just tried on version of the Visual Studio Extesnsion and it's threw and error which also caused the packages.config to not be there. There's an update out which is working fine, I'd suggest making sure the extension is on the latest and trying a new site.

Apr 19, 2018 15:11

Hi Scott! I believe I am using the latest version - It does give a type of error message though: 'Solution is not opened or not saved. Please ensure you have an open and saved solution.' I just thought it meant that I need to save the solution.. but packages.config is not there.

Apr 20, 2018 10:05

You shouldn't get any errros popping up when creating an episerver site, any errors may crash out the process. It might be a bug with VSC, I'd raise it with episerver support as an issue

Apr 20, 2018 10:21

Oh well, my report will probably 'drown' in that long list of bugs.. but thanks:)

Apr 20, 2018 12:06


I wish you would take a more proactive approach towards resolving this problem. Episerver support & development teams devote a large amount of resources towards solving problems like this. It's possible that something in your environment is causing the problem -- support could troubleshoot that. Or maybe you have discovered a bug – it happens all the time. By reporting it, there’s a good chance it’ll be fixed in an upcoming release. That fix would benefit both you and the entire community of developers who use the product.

Apr 20, 2018 16:59

Quite frankly Bob this don't seem a very good response coming from an Episerver Employee, As a long time partner of Episerver I've been trying to help Soren S to solve this issue but he seems to be getting quite frustrated and to be fair I don't blame him seeing as he's just trying to get the base install of Episerver working. The first place every developer comes is to the forurms to see if you can get help from the community as it might be something someone else has tackled and it's always been that standard Episerver dev approach to ask here before raising something to a busy support team that's got a lot on their plate. For someone whos' obviously new to the platform and having issues it would be better if you have a more helpful response than seemingly telling him off about his approach to tackling the problem.

Apr 20, 2018 17:10

I apologize if my reply was not helpful. I was simply trying to encourage him to use the Epi support team to help resolve the problem.

Apr 20, 2018 17:13

No worries:) I did actually write an email directly to some people at episerver, but they haven't responded yet. Perhaps I'll also try to register it on the official list now.
In the meantime, could someone perhaps use a working episerver extension to generate a new VS project (MVC/Search) and then upload that as a zip for me..? (if not already available somewhere)
Best regards,

Apr 23, 2018 15:45
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.