Try our conversational search powered by Generative AI!

Service API Get Catalogs 404



i have found this topic

I am trying to get the Catalog (

But getting 404.

My users are setup in the system ( i have 2) one user is in WebAdmin and WebEditor groups and the second one is in Administrators and Web/Admin/Editor.
I have configured the permissions in the Admin mode so that both Administrators and WebAdmins have read/write permissions for Service Api

The SSL is disabled in Web.Config -> ApplicationSettings

I have also tried to 

<add key="episerver:serviceapi:maphttpattributeroutes" value="false" />

I am using postman.

1. I generate a token for the user (tried with both users).
2. Than in postman i select [GET] to (CMS) http://localhost:14432/episerverapi/commerce/catalogs
3. In Postman, under Authorization, i select Type : Bearer Token and past the token  that i got under step 1.
4. Click [Send]

Result: 404

My catalog is very simple. I have a catalog called Alloy and just one Category page.

As mentioned the get version (currently on version 5.2 (is working)) and the Token is generated.
But as soon as i try a get operation concerning getting any catalog data (also tried to get my specific catalog named Alloy) i get 404

I have setup the the Alloy and than installed Commerce.
The site is up and running and i can see both my Category page and the default Alloy pages.

Any suggestions?

Nov 27, 2018 15:21
<add key="episerver:serviceapi:maphttpattributeroutes" value="false" />

This should not be used unless you have other code that specifically calls MapHttpAttributeRoutes

And how do you generate the token? don't you have to post to episerverapi/token to get it? 

Nov 28, 2018 8:52

As it sometimes happens, it solved it self, very strange.
I restarted the computer and it was working???

Dec 12, 2018 8:11
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.