Try our conversational search powered by Generative AI!

DXC FindSearchProvider - 500 error on Search Index page


Commerce 12.11.0

FindSearchProvider 10.0.2

I had configured FindSearchProvider and until recently this was working in the DXC environments which had "episerver:FindServiceUrl" and "episerver:FindDefaultIndex" in appSettings.

Recently the Catalog search functionality in Commerce Manager stopped working. When navigating to the Administration -> System Settings -> Search Index page on DXC, I get the following error :

I'm puzzled by the error as to why the Indexer is expecting a "connectionStringName" given I'm using the FindSearchProvider.

This is working in my local dev environment with my Find developer index. 

Here's my Mediachase.Search configuration, which was working previously when deployed to DXC.

I've tried various resolutions on the DXC environment i.e. restarting the App service, using my developer index in the appSettings, however without success.

Appreciate any suggestions to resolve this.


Jul 01, 2019 2:46

Your Indexers should look like this

<Indexers basePath="indexcontainer" connectionStringName="EPiServerAzureBlobs" > 

because the indexer need access to the blob storage for storing indexing metadata 

Jul 01, 2019 8:36

Thanks Quan, that worked like a charm.

I didn't realise that the blob storage setting was also required for the FindSearchProvider Indexer. Maybe the documentation for configuring FindSearchProvider should be updated to highlight the necessary configuration for DXC.

Any ideas as to why this was working before on DXC without the "connectionStringName" on the Indexer ? Would it have been storing the indexing metadata on the filesystem (under App_Data) ? For some reason this has regressed now.

Thanks again for your help

Jul 01, 2019 9:35
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.