Virtual Happy Hour this month, Jun 28, we'll be getting a sneak preview at our soon to launch SaaS CMS!

Try our conversational search powered by Generative AI!

Can't build WikiX

I just downloaded WikiX 1.0, but I can't build it. The WikiParser class uses an object of class WikiSyntax of which there is no trace in the solution. Is the package missing a file or did I do something wrong?
Sep 08, 2009 9:28

Hi Magnus

WikiSyntax is in the file WikiSyntax.dll that you should find in a folder called WikiSyntax in the root of the project. You might need to adjust the references to include that assembly if it's not already there. It's basically precompiled regex classes for the parsing of wiki expressions.

 Good luck


Sep 09, 2009 5:14
Aah, should have checked the references of course :) Found it in the EPiServer.Research.Wiki\Core\bin folder.
Sep 09, 2009 8:27

I have more problems now though... The save/cancel buttons in the edit dialog don't work (nothing happens when they are clicked) and neither does the search (404 on /en/WikiSearch/).

I'm running R2SP2, not R2SP1 as listed in the prerequisites, could that be a problem?

Sep 09, 2009 10:34
I am also stuck at the same step as Magnus, can't get it to save / cancel. Something with the webmethods?
Sep 21, 2009 8:59


Check the responses in Firebug. One problem can be the maxjsonlength, 


Regards Per

Sep 21, 2009 13:04

The Save/Cancel button problems does in deed sound like a JQuery related issue. Which browser are you guys using?

The 404 on the search could be the ASP.NET UrlRouting that's not registered correctly - I belive it registers a bit differently in IIS7 than in earlier versions. However it could also be related to how the wiki has been set up.

The wiki is supposed to be below a root wiki node. A url like "/en/WikiSearch/" doesn't indicate that it's below a root node (unless the start page it-self is a root wiki). Try to add a WikiRoot below the start and see if that solves the problem. Oh, and try it with a url like "/en/Wiki/WikiSearch/query" since that's the pattern it will match. 

Sep 21, 2009 15:35
I have the Wiki root as start page so maybe that's the problem. I will try to add a different start page when I have time to do so. Thank you!
Sep 21, 2009 16:24
I am also using it as a startpage, will try it and get back... Thanks!
Sep 21, 2009 16:30
Can't solve the issues I am having, think I have tried everything.

I have a clean EpiServer 5.2.375.236 site. Downloaded the WikiX-project from Codeplex, updated the references to EPiServer to 5.2.375.236 and compiled it.

Added a reference to the Wikiproject to my EpiServer-site, and copied all files from EPiServer.Research.Wiki-folder to the root of my webproject. Made the web.config changes and imported the complete package.

Everything seems to work except Search (I get a 404, on url: http://localhost:6666/en/WikiX/WikiSearch/asdasd) and Save/Cancel-buttons when I try to edit a section (nothing happens).

When browsing http://localhost:6666/EPiServer.Research.Wiki/Core/SaveArticleAjax.aspx/UpdateArticle I receive a "RightClickMenu requires a header control on the page." Tried inheriting from System.Web.UI.Page instead of TemplatePage, but it didn't help.

Any ideas on what I have done wrong?

Sep 28, 2009 15:53

If you are running IIS5 you might want to try commenting out the http module IIS5WebServicePostModule.

Also try to move the UrlRoutingModule up to the top. This helped fix the 404 errors while searching.

Oct 02, 2009 12:02

 I am using the Development Server in VS 2008..

Tried moving the UrlRoutingModule to the top, and that fixed my 404 on the searchpage, but I still can't edit/create content.

Oct 02, 2009 13:04

I'm getting a 404 on the jquery post to /EPiServer.Research.Wiki/Core/SaveArticleAjax.aspx/UpdateArticle. I've modified the SaveArticleAjax.aspx enough to be able to browse it (without content), so the URL to the aspx isn't the problem. Seems like it interprets "UpdateArticle" as a part of the URL and not the method name.


Oct 09, 2009 12:36
It seems you can't run webmethods on your server. We are working on a fix in the Wiki for next week.
Oct 09, 2009 20:51

Has a fix for this been released?

Dec 02, 2009 9:56
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.