SaaS CMS has officially launched! Learn more now.

Set the default page to go to after login in CMS?


Hey All,

i was wondering if there is a setting to go to the edit-mode of CMS after login immediately instead of the start page (with the gadgets)...

Hope there is a quick setting for this... i thought there should have been a setting in the episerver.config sitesettings, but i couldnt find a thing..


thanks in advance

Nov 07, 2012 15:10

Could you provide more information about what you do and what you would like to happen, cms version etc.

Nov 07, 2012 16:15

Hi Per,

Using Episerver 6 R2...

Ok i have my site localhost... Now when i want to go to the CMS.. 

i go to localhost/cms ... I now get the login page.. I login succesfully but the page i see then is the START Dashboard, see image below..

Start dashboard is the page where you can add you gadgets(widgets) etc.

I want to immediately let it redirect to the edit mode of the CMS section where i see my pagetree.. 

The url to edit mode is localhost/cms/CMS/Edit/Default.aspx

So where can i change that it should not bring me to the start dashboard, but immediately to the localhost/cms/CMS/Edit/Default.aspx


I hope this is clear now... I hope you can help!


Edited, Nov 07, 2012 16:55

if you just write locahost/cms/edit and then login you will be redirected to edit mode and the pagetree.

Or if you av a login button you could just click edit mode option in the right click context menu.


Nov 07, 2012 17:01

Ok you see... the client wants a easier way to get to the edit mode with just going to the site and then put a /cms behind it, login and voila, they see the page tree. 

So without having to enter the complete edit-mode url /cms/CMS/edit/ (this is the correct url).. /cms is easier to remember then the other one.

It would also save them a couple of extra clicks after the normal login which bring them to the start dashboard.

I thought this should have been a simple setting in the episerver.config or web.config.. 


Nov 07, 2012 17:13

Do a redirect in the IIS or create a httpmodule that redirects the users to complete url.

Or you could change the edit mode url in the config files so it's not cms/cms/edit but just cms/edit. An extra /edit after cms isn't that hard to remember.

Nov 07, 2012 17:22
Nov 08, 2012 15:41
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.