Virtual Happy Hour this month, Jun 28, we'll be getting a sneak preview at our soon to launch SaaS CMS!

Try our conversational search powered by Generative AI!

Active Directory Roles Out of Sync

Vote:
 

I recently made some changes and added a custom Active Directory Role Provider. It works, because when you search in the admin panel Search Users/Groups I can see the correct roles. However, when assigning access through Add Users/Groups, I seem to get a strange half complete list of groups I had in there from before the change. How can I update the roles in that window? Why are the two searches different?

#151030
Jul 07, 2016 11:21
Vote:
 

Logging in a user that has the roles usually works to update them.

#151033
Jul 07, 2016 12:46
Vote:
 

Thanks for the reply Daniel - I have logged out and logged in but the roles are still not updated, is there any scheduled job I can run to flush them out and update with the new ones?

#151045
Jul 08, 2016 10:24
Vote:
 

Does your user have those missing roles?

#151046
Jul 08, 2016 10:33
Vote:
 

Yes

#151047
Jul 08, 2016 10:35
Vote:
 

And it's when you are trying to assign access for a specific page in admin where they don't show up? Or when creating new user?

Have you got very many roles in AD? Think there's a limit on 1000 default...

#151051
Edited, Jul 08, 2016 14:04
Vote:
 

Yes it's when assigning access rights in "Set Access Rights". I had already hit the limit on number of roles, which is why I had to implement the custom role provider, because I am now targeting a specific OU that contains only roles relevant for EPiServer. There's only about 10 in there now.

#151052
Jul 08, 2016 14:18
Vote:
 

Hmm weird. Tried using the original AD provider but limit to ou in connection string like?

LDAP://mail.company.se/OU=Users,DC=company,DC=local

#151059
Edited, Jul 08, 2016 19:02
Vote:
 

Hi Daniel

I couldn't get this to work. Not sure where to go next. I can see where these roles are coming from - tblSynchedUserRole. Is it safe to wipe this table and hope it fills them with the correct roles?

Thanks

#151153
Jul 12, 2016 15:53
Vote:
 

Haven't tried it myself. Backup db and give it a try :)

#151157
Jul 12, 2016 17:14
Vote:
 

So I wiped the table and logged in again, but the roles didn't sync. I had to manually enter the roles into this table, which did work. It seems for me the autosync is not working - a minor annoyance but I'll have to live with it.

#151213
Jul 13, 2016 13:50
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.