Try our conversational search powered by Generative AI!

Error during basic install

I am getting an error at a client site when I get to the final stage of the EPiServer installation - Install basic content. I select only start page without content and in English and I get the following error: Exception: File or assembly name qyeksxv9.dll, or one of its dependencies, was not found.[]. Stacktrace: at System.Reflection.Assembly.nLoad(AssemblyName fileName, String codeBase, Boolean isStringized, Evidence assemblySecurity, Boolean throwOnFileNotFound, Assembly locationHint, StackCrawlMark& stackMark) at System.Reflection.Assembly.InternalLoad(AssemblyName assemblyRef, Boolean stringized, Evidence assemblySecurity, StackCrawlMark& stackMark) at System.Reflection.Assembly.Load(AssemblyName assemblyRef, Evidence assemblySecurity) at System.CodeDom.Compiler.CompilerResults.get_CompiledAssembly() at System.CodeDom.Compiler.CompilerResults.get_CompiledAssembly() at System.Xml.Serialization.Compiler.Compile() at System.Xml.Serialization.TempAssembly..ctor(XmlMapping[] xmlMappings) at System.Xml.Serialization.XmlSerializer..ctor(Type type, String defaultNamespace) at System.Xml.Serialization.XmlSerializer..ctor(Type type) at EPiServer.Enterprise.Transfer.PageTypeTransfer.Import(XmlTextReader input) at EPiServer.Enterprise.DataImporter.ᐁ(Stream ) at EPiServer.Enterprise.DataImporter.Import() And the file or assembly name changes each time i try the process. I can't find anything on the forums about this. Any ideas? Thanks in advance, Bevan
Mar 03, 2005 4:44
I am not sure what the source of the error was, but instead of finishing the install I logged into the admin area and after setting the startpage, the site now works. What event sources does EPiServer require when it logs errors in the application log?
Mar 04, 2005 1:17
The install was done on a Windows Server 2003/IIS6 and the website was created under a separate application pool. The identity of the application pool is set to a domain user so that Windows NT authenticated security can be used to access the SQL database. This is the cause of the problem mentioned above. It works fine under the default Network Service account. I have been throught the the default permissions for IIS6 [ ] but still get the same error. Is an EPiServer application limited to running under the Network Service account? Or am I missing the correct permissions? Thanks.
Mar 08, 2005 23:20
The .NET class XmlSerializer will dynamically generate assemblies with strange looking names, just as ASP.NET does. The difference is that it stores the files in the windows temp folder and not the ASP.NET temp folder. So, the reason is often missing write access to c:\windows\temp or the domain user temp folder. You can use FileMon from SysInternals to trace the disk activity to see exactly where it tries to access the dll's it generates. It could also be missing execute permissions on the c:\windows\\....\csc.exe which will handle the actual compilation.
Mar 09, 2005 19:17
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.