Try our conversational search powered by Generative AI!

Issues installing Optimizely Foundation


Hi all.

As described in Patric Lams blog post I tried installing Foundation based on Net 5.

In the Net 5 branch I was not helped much by the installation notes in Readme file, due to lacking version of NodeJs and more. So for this I used the develop branch instead. MUCH BETTER !  :) 

After juggling with the NodeJs versions a bit (using Node Version Manager) I found out that the 14.17.3 worked fine. Version 16.x.x have me conflict issues with webpack and node-sass, among other thing.

However I'm stuck in setup not being able to log in as the current user in my local database server.  I use Windows Auth and has set up the Security policy as instructed in the installation notes.

The Sql Server name works when using ssms prompt.

The issue looks like its related to build.ps1 file not being signed.  I've set the permission for usergroup Users for the entire folder and set this through powershell

Set-ExecutionPolicy -Scope Process -ExecutionPolicy Bypass

 The error message stands.

Any thoughts what it could be?

Oct 08, 2021 15:07

I would suggest to run 

Set-ExecutionPolicy -ExecutionPolicy Unrestricted

in administration mode, just to see how it works

Oct 08, 2021 15:43
Jonas Boman - Oct 08, 2021 15:52
And presto. Simple as that.
Thanks Quan Mai!
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.