SaaS CMS has officially launched! Learn more now.

Social Reach does not show

Vote:
 

Hi!

I am having some trouble installing the Social Reach add-on. I have tried installing it via the add-on store, package manager and package manager console. But none of them seems to work. 

Current status:
I installed the add-on with package manager console: Install-Package EPiServer.Social.
Under references I now find EPiServer.Social, EPiServer.Social.Configuration, EPiServer.Social.Models, EPiServer.Social.Providers. 
In my packages.config this line was added: 
No changes in my web.config.
In my modules folder, there is a EPiServer.Social folder.

But the social reach add on doesn't appear in my global menu. What am I missing?

#178768
May 22, 2017 9:29
Vote:
 

It seems to be a translation issue. The social reach tab is there, but it's not showing because it's missing translated text. The same thing happens for the google analytics add-on. 
I have tried norwegian and swedish, both with the same issue. If I change to english, it works fine.

How do I fix this?

#178775
May 22, 2017 13:10
Vote:
 

Hi,

I tried to install SocialReach and changed language to Swedish, but the add-on still display (in English). I don't know how to reproduce. Maybe you lacking this line in your web.config

<localization fallbackBehavior="Echo, MissingMessage, FallbackCulture" fallbackCulture="en">

If not you can try to workaround by do following:

  • Get EPiServer.Social_EN.xml, EPiServer.Social.Providers_EN.xml in EPiServer.Social.zip file (under your "modules" folder).
  • Change language ID in those xml files to your language ID (ex: "sv" for Swedish).
  • Put those xml files into <YourSite>\Resources\LanguageFiles (this path define in web.config)
  • Refresh site to see if it affected.

/DT

#178891
May 25, 2017 11:54
Vote:
 

Ah, thank you!  I had this line, but it was only set to 'Echo'. I added MissingMessage, FallbackCulture, and it works!

#178975
May 29, 2017 10:27
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.