Don't miss out Virtual Happy Hour this Friday (April 26).

Try our conversational search powered by Generative AI!

Installation fails because of aspnet_regsql



When trying to install new site with database (or just database), I get an error (below).

I also get this error when trying to run aspnet_regsql from cmd, so I guess this isn't a episerver-problem, but all help is appreciated.


At C:\Program Files (x86)\EPiServer\CMS\7.0.586.1\Install\System Scripts\Install Database (SqlServer).ps1:126 char:18
+ New-EPiSqlSvrDB <<<< `
System.ApplicationException: Process C:\Windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_regsql.exe exited with errorcode 2:
Start adding the following features:

An error occurred during the execution of the SQL file 'InstallMembership.sql'. The SQL error number is -2 and the SqlException message is: Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding.
SQL Server:
Database: [dbDemosite]
SQL file loaded:

Commands failed:

EXEC sp_addrolemember N'aspnet_Membership_BasicAccess', N'aspnet_Membership_FullAccess'
EXEC sp_addrolemember N'aspnet_Membership_ReportingAccess', N'aspnet_Membership_FullAccess'

SQL Exception:
System.Data.SqlClient.SqlException: Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding.
at System.Data.SqlClient.SqlInternalConnection.OnError(SqlException exception, Boolean breakConnection)
at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj)
at System.Data.SqlClient.TdsParserStateObject.ReadSniError(TdsParserStateObject stateObj, UInt32 error)
at System.Data.SqlClient.TdsParserStateObject.ReadSni(DbAsyncResult asyncResult, TdsParserStateObject stateObj)
at System.Data.SqlClient.TdsParserStateObject.ReadNetworkPacket()
at System.Data.SqlClient.TdsParserStateObject.ReadBuffer()
at System.Data.SqlClient.TdsParserStateObject.ReadByte()
at System.Data.SqlClient.TdsParser.Run(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj)
at System.Data.SqlClient.SqlCommand.RunExecuteNonQueryTds(String methodName, Boolean async)
at System.Data.SqlClient.SqlCommand.InternalExecuteNonQuery(DbAsyncResult result, String methodName, Boolean sendToPipe)
at System.Data.SqlClient.SqlCommand.ExecuteNonQuery()
at System.Web.Management.SqlServices.ExecuteFile(String file, String server, String database, String dbFileName, SqlConnection connection, Boolean sessionState, Boolean isInstall, SessionStateType sessionStatetype)

at EPiServer.Install.Common.Installers.ExecuteProcessInstaller.Install(IDictionary stateSaver)
at EPiServer.Install.InstallationManager.Install(Installer installer)
at EPiServer.Install.SqlServer.SqlServerInstallationManager.InstallAspNetSchema(String sqlServerName, Nullable`1 sqlServerPort, String databaseName, String loginName, String loginPassword)
at EPiServer.Install.SqlServer.SqlServerInstallationManager.CreateDatabase(String sqlServerName, Nullable`1 sqlServerPort, String databaseName, String loginName, String loginPassword, String epiServerSqlScriptPath, Boolean isEPiServerScript, Boolean installAspNetSchema, Boolean installWFSchema, Int32 progressPercent)
at EPiServer.Install.SqlServer.Cmdlets.NewDatabaseCmdlet.ProcessRecord()
at System.Management.Automation.Cmdlet.DoProcessRecord()
at System.Management.Automation.CommandProcessor.ProcessRecord()

Nov 02, 2012 15:19

System.Data.SqlClient.SqlException: Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding.

It looks like connection problem.

Could you verify your database connection options specified in new site wizard are correct and also check that specified SQL Server instance is available?

Nov 02, 2012 16:04


I have verified that (and if it's not valid, you cannot get to next step in the vizard).

The SQL Server instance is available, and I have also tried to create a new instance and tested that with the same error.

Nov 02, 2012 16:07

did you get the installation sorted, and how?



Jul 01, 2013 10:42

Does someone have a clue how to solve this?

Jul 08, 2013 8:59

I would sugest you download web platform installer or run the sql installer once again reparing you installation. Also make sure you have enebled the sql browser tcpip and all that stuff for the sql server as well. If you install the sql server via web platform installer from Microsoft you will have an installation that should work without any other modifications. If you have installed it your self you might need to enable some of the above features.

Jul 08, 2013 12:14

have you enabled mixed mode for sql as well?

Jul 08, 2013 12:15

web platform installer for SQL Server, or for what?


Yes, running mixed mode

Jul 08, 2013 12:38

I always install all my sql IIS and .net stuff with the platform installer and it has always been enough to get every thing i need for EPiServer development.

Edited, Jul 08, 2013 12:54

I did not do the sql server installation myself, but looking in the Web Platform installer it seems  OK.

But on second thought, I dont think I use the Compact version but the full 2012 RTM (11.0.2100.60)

I´ve done EPiServer installations with CMS 6 without issues.

Edited, Jul 08, 2013 13:11

It looks like you only got the Compact version av SQL server 2008 try to install the sql server 2008 express r2 service pack 2 that you can find at the top of the list.

Jul 08, 2013 13:45

How can I use the 2012 version instead of having several sql versions?

Jul 08, 2013 14:09

You just uninstall all other versions. But you can run diffrent versions of sql at the same time. Just choose the instance of sql you would like to install to when installing episerver. If you runt 2012 it might work with epi cms 7 not sure though  how it work with older versions of episerver. So if you know that you work with earlier installations of episerver websites i sugest you install 2008.

Edited, Jul 08, 2013 18:54
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.