Try our conversational search powered by Generative AI!

Tuple<T1,T2> Problem with ImageEditor


Hello everyone, I have a problem with the ImageEditor. When I load a picture and try to change it (like resize for example), I'm using the options Constrain proportions and Save as a copy in Page files and Quality high (even though replace original yields the same result). I click apply, and then the OK button. Now instead of getting a "save as" dialog I just get a dialog with this error message:


Compiler Error Message: CS0433: The type 'System.Tuple<T1,T2>' exists in both 'c:\Windows\Microsoft.NET\Framework\v4.0.30319\mscorlib.dll' and 'c:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root\495c83ab\dae76742\assembly\dl3\4124893d\00b1cf5d_d639ce01\System.ComponentModel.Composition.DLL'

Source Error:

Line 31:                         <ItemTemplate>
Line 32:                             <li>
Line 33:                                 <asp:HyperLink runat="server" Target="_blank" Text="<%# ((Tuple<string, string>)Container.DataItem).Item1 %>" NavigateUrl="<%# ((Tuple<string, string>)Container.DataItem).Item2 %>" />


Any ideas on how to resolve this? I feel like I can't think of anything else :-(

For reference I am using CMS 7.1.2 but also tried on 7.0.1, my app-pool runs .NET framework v4.0, i'm running windows server 2008 R2 Standard 64bit. I've tried these browsers: IE10, IE9, chrome and firefox. 

The thing I tried that I had the highest hopes of working was this:

also noted here:

As far as I can understand the problem is that there are two version of "Tuple" in the System namespace, one from System.ComponentModel.Composition.dll and one from mscorlib.dll. But how to get around this I have no idea! :(

Is there some fix from EPiServer possibly?


Oct 18, 2013 18:36

And yes, I have tried clearing the ASP.NET cache and browser cache without any result.

Oct 24, 2013 15:16

Finally I found the problem!! To make a long story short there was a version of the System.ComponentModel.Composition.dll referenced in my project. Everywhere I looked on the internets it looked like it should be that version also (2009.22.10.0), but of course It was not correct. Removing that file solved my issue.

Now I can only hope that my confused problem can help someone else :)

Nov 18, 2013 9:43

It helped me! Thanks!

Edited, Nov 26, 2013 23:07

Thanks for your sharing this secrete.

Nov 27, 2013 2:06

Thank you for posting the solution to this one :)

Aug 02, 2016 13:36
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.