Try our conversational search powered by Generative AI!

Strange Block Problem


I've run into an issue regarding blocks that's really weird.  I've followed Anton K's tutorial but for some reason, I can't create a block inside the CMS.  I tried the Block Type specific method and my page will show the block, however I get a "There is no rendered for "MyBlockType"" message on the page screen. I can create a ContentArea for a block, but when I go to create one through the CMS, I don't even have the "New Block" option. If I try it through the Create Content button at the top, there are no block types even available to me. I have BlockTypes defined and have views (using Razor) in my Views/Shared/ folder as well as a BlockController/BlockModel/BlockView in it's own folder (View/MyBlock/MyBlock.cshtml)

Here are some screen shots:

New Block from button

New Block Content Area

Feb 22, 2013 23:05

Hey Corbin, Try checking the permissions on the Global library node in the tree.  It should be located under the root node.

Feb 24, 2013 5:59

I'm logged in as an administrator.  I checked all the permissions and they are all set right. We didn't make any changes to the default settings.

Feb 25, 2013 17:03

Hmm, it looks quite broken. Can you open the a JavaScript console and see if you get any errors?

Do you have a root page configurared for your blocks (check the site settings page)?

Feb 26, 2013 7:13

Looked as the JS console in Firebug and it's slammed full of errors from dojo.js


"Error: Unable to load /Admin/cms/Stores/contenttype/?query=getsuggestedcontenttypes&requestedTypes=EPiServer.DataAbstraction.BlockType&dojo.preventCache=1361896847650 status:500
Line 15"


I don't know if it was a cache issue or what but I'm not getting the above error any more. Still no blocks available.


Edited, Feb 26, 2013 17:43

I think I figured out the problem. My original set up was for multiple sites. We had a change of plans and decided to go with a singlular site. When I removed the sites we were not going to use, I DID NOT uncheck the "use site specific block folder" option. For some reason EPi7 freaks out when that option is set for a single site config. As soon as I turned it off, all of my blocks are available.

Feb 26, 2013 18:26

Ok, I'll report a bug for that but I'm glad that you solved it.

Feb 27, 2013 8:19
May 26, 2016 16:10
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.