SaaS CMS has officially launched! Learn more now.

Serious problem with Forms Edit

Vote:
 

Hello,

I've been upgrading a Relate site to V7 and have hit a fairly major problem where forms edit will not work.

When selecting forms editing nothing happens and when selecting on-page editing I get the following error in Firebug:

http://siteurl/clientname/shell/Stores/metadata/?type=EPiServer.Core.ContentData&modelAccessor=%7B%22contentLink%22%3A%223_14250%22%7D&dojo.preventCache=1366114416958

Which when expanded shows an object reference error as follows:

[NullReferenceException: Object reference not set to an instance of an object.]
   EPiServer.Editor.TinyMCE.PlugInAssembler.AddSettings(TinyMCESettings settings) +84
   EPiServer.Editor.TinyMCE.TinyMCEInitOptions..ctor(InitType initType, IDictionary`2 options, TinyMCESettings settings, IContent content) +91
   EPiServer.Editor.TinyMCE.TinyMCEInitOptions..ctor(InitType initType, TinyMCESettings settings, IContent content) +46
   EPiServer.Cms.Shell.UI.ObjectEditing.EditorDescriptors.XhtmlStringEditorDescriptor.ModifyMetadata(ExtendedMetadata metadata, IEnumerable`1 attributes) +321
   EPiServer.Shell.ObjectEditing.ExtensibleMetadataProvider.ApplyExtendersToMetadata(ExtendedMetadata metadata, IEnumerable`1 attributes, IEnumerable`1 metadataHandlers) +121
   EPiServer.Shell.ObjectEditing.ExtensibleMetadataProvider.GetMetadataForProperties(ExtendedMetadata parent, Object container, Type containerType, IMetadataProvider customProvider) +241
   EPiServer.Shell.ObjectEditing.ExtendedMetadata.get_Properties() +235
   EPiServer.Cms.Shell.UI.ObjectEditing.SettingsPanelMetadataExtender.ModifyMetadata(ExtendedMetadata metadata, IEnumerable`1 attributes) +43
   EPiServer.Shell.ObjectEditing.ExtensibleMetadataProvider.ApplyExtendersToMetadata(ExtendedMetadata metadata, IEnumerable`1 attributes, IEnumerable`1 metadataHandlers) +121
   EPiServer.Shell.ObjectEditing.ExtensibleMetadataProvider.CreateMetadata(IEnumerable`1 attributes, Type containerType, Func`1 modelAccessor, Type modelType, String propertyName) +493
   System.Web.Mvc.AssociatedMetadataProvider.GetMetadataForType(Func`1 modelAccessor, Type modelType) +129
   EPiServer.Shell.UI.Rest.MetadataStore.Get(String type, String modelAccessor) +73
   lambda_method(Closure , ControllerBase , Object[] ) +178
   System.Web.Mvc.ReflectedActionDescriptor.Execute(ControllerContext controllerContext, IDictionary`2 parameters) +260
   System.Web.Mvc.ControllerActionInvoker.InvokeActionMethod(ControllerContext controllerContext, ActionDescriptor actionDescriptor, IDictionary`2 parameters) +38
   System.Web.Mvc.<>c__DisplayClass13.<InvokeActionMethodWithFilters>b__10() +123
   System.Web.Mvc.ControllerActionInvoker.InvokeActionMethodWithFilters(ControllerContext controllerContext, IList`1 filters, ActionDescriptor actionDescriptor, IDictionary`2 parameters) +308
   System.Web.Mvc.ControllerActionInvoker.InvokeAction(ControllerContext controllerContext, String actionName) +853472
   EPiServer.Shell.Services.Rest.RestControllerBase.ExecuteCore() +241
   System.Web.Mvc.ControllerBase.Execute(RequestContext requestContext) +334
   EPiServer.Shell.Services.Rest.RestHttpHandler.ProcessRequest(HttpContextBase httpContext) +274
   System.Web.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +913
   System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +165

When creating a brand new site from scratch I don't get this error, it seems to be caused by the upgrade.

The process I adopted was:

  • Copy site to be upgraded
  • Upgrade site, CMS, followed by Community - this was only done to update the DB
  • Create blank V7 site
  • Copy files from site to be upgraded to V7 site - templates only, no dlls or config files
  • Update config files as appropriate - point to upgraded DB, correct VPPs etc
  • Fix build errors (there were lots!!)

I'm guessing this is a config issue but would be grateful if anyone could provide suggestions. Has anyone encountered this before?

Thanks in advance,

Mark

#70279
Apr 16, 2013 15:01
Vote:
 

Have you tried this?

http://talk.alfnilsson.se/2013/03/06/nullreferenceexception-from-tinymcesettings-inputtinyoptions-getactivetoolshtml-and-toolbarrow/

#70386
Apr 18, 2013 11:09
Vote:
 

I have the same problem and tried the solution on that blog, but no success.

#71359
May 16, 2013 12:39
Vote:
 

I have the same probelm with a site I have upgraded from 6R2 to 7.5. I am not able to edit pages that uses the TinyMCE editor. I have also tried to access the page type from the administration and I get the error Mark A has posted.

I tried the solution Linus posted but it didn't solve the problem, but I did notice something strange. I have upgraded multilple sites the last month so I checked the database of one of the other sites. In this database the view mentioned in the solution Linus has posted 'VW_EPiServer.Editor.TinyMCE.ToolbarRow' doesn't exist. Instead there is a view called 'VW_EPiServer.Editor.HtmlEditorSettings' so I am wondering if I have missed a part of the upgrade process and therefore hasn't gotten the database into the right state?

Update:

Just restarted my local IIS and used a private browser to avoid chaching issues and now the site works! So the solution provided by Linus did solve my problem. I still question why I have different databases and maybe this should be looked into some more.

#85442
Edited, Apr 25, 2014 10:49
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.