SaaS CMS has officially launched! Learn more now.

Uploading a file larger than 30MB fails

Vote:
 

I found out that trying to upload a file larger than 30Mb fails today. Reproduced it in IE/FF and Chrome, so it must be a server-side limitation. The maxRequestLength is set to around 1Gb in web.config, unchanged default setting from CMS7 core installation. I'm having this issue both locally IIS8 / Win8 and on IIS7 / Win Serv. 2008 R2.

I can't find any documented limitation for file uploads, so i guess this is a bug?

I could probably get around this using Webdav or a VirtualPathNonUnifiedProvider, but that's far from ideal.

#71243
May 14, 2013 20:02
Vote:
 

Could it be maxRequestLength for the specific location path as well? Have had problem with this before and i think I added it both for location path, system.webserver and system.web. but might be a bug as well :)

#71247
May 14, 2013 20:26
Vote:
 

Could it be that you also have to set maxAllowedContentLength as well? 

http://stackoverflow.com/questions/6327452/which-gets-priority-maxrequestlength-or-maxallowedcontentlength

#71248
Edited, May 14, 2013 20:48
Vote:
 

You are correct, I added this for location path secure/UI:

    <system.webServer>
      <security>
        <requestFiltering>
          <requestLimits maxAllowedContentLength="1048576000" />
        </requestFiltering>
      </security>
    </system.webServer>

I guess it's a bug in the default setup of web.config then :) Thanks a lot!

#71249
May 14, 2013 20:58
Vote:
 

Yup, just figured it out Arild.

#71250
May 14, 2013 20:58
Vote:
 

Hi all, and thank you for sharing this configuration setting! I've added a section about it under asset management in the Developer Guide of EPiServer CMS.

#80699
Jan 30, 2014 9:37
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.