Try our conversational search powered by Generative AI!

Running localhost



I am running episerver on win2k3 iis6 all runs fine. I am trying to run locally on my windows7 laptop but i am getting issues with missing resources when logging in e.g



The above folders report 404. I can login but everything looks wrong due to missing js and stylesheets.

all my physical path settings in episerver.config file for virtual path  are correct.

The site is running in classic 2 app pool with network service as the account. This account has full permissions to all the folders setup for virtual paths.  Am I missing something?  Also when attempting to hit the home page localhost/en-GB/ I get 404 however site works fine on dev server and also if I run the site using visual studio and cassini everything works.




Sep 02, 2013 9:40

Is it possible for your setup to run in Integrated Mode?

Sep 02, 2013 10:13


Changing to integrated mode gives me error 500 there is a problem with the resource you are looking for.



Sep 02, 2013 11:12

Right I have managed to fix this.  Possibly one of two things that fixed it. First I changed back to classic and added wildcard mapping in iis7.5. Second I generated a demo license and copied that over. I now have working site well almost when i try to login i get Unknown server tag 'EPiServerUI:Login'.



Sep 02, 2013 12:07

You can try to compare web.config file with some sample site. Sounds like some page using directives are not included. For instance:

<location path="cms">
    <pages enableEventValidation="true">
        <add tagPrefix="EPiServerUI" namespace="EPiServer.UI.WebControls" assembly="EPiServer.UI" />
        <add tagPrefix="EPiServerScript" namespace="EPiServer.ClientScript.WebControls" assembly="EPiServer" />
        <add tagPrefix="EPiServerScript" namespace="EPiServer.UI.ClientScript.WebControls" assembly="EPiServer.UI" />


Sep 02, 2013 14:44
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.