Try our conversational search powered by Generative AI!

Episerver local environment setup


Hi Team,

I am trying to connect Episerver CMS in localhost (IISExpress) using local administrator account but getting error: 

The trust relationship between the primary domain and the trusted domain failed.

I am able to load the actual web application (localhost:port/Mysite) but when I try to log in (localhost:port/Mysite/episerver) getting the above-mentioned error. 

Can someone please help me to troubleshoot this issue as this error stopping my deliverables.

Is there any way or hack, something I can skip the Episerver authentication layer so that I can access CMS directly in my local.

Thank you in advance.

Edited, Jun 01, 2020 18:59

Hi SasiRekha,

Are you getting the error while login or you are not able to access the /episerver login page?

Jun 05, 2020 15:12

Hi Ravindra,

I got this error after login with my windows credentials.


And I am trying to connect EpiserverDB from local, pointing to our DEV server database, not the local database. 

Jun 05, 2020 18:44

I think windows credentials will not work if you are using databases from other server.

Try these things-

  1. Are you able to connect the databases from your SQL management studio? 
  2. If not then please pull those databases on your local and then give a try.

One more thing is there any other Episerver site is working on your local? Like Alloy or any other client site?

Edited, Jun 05, 2020 18:52

Hi Ravindra, Thanks for your reply.

I can not get a copy of the dev server DB into my local since it won't be allowed in my organization.

And one more thing I need to mention here. The actual dev server I am connecting from my local, it does not have the Episerver license yet.

Only Production and pre-production servers have the Episerver license. Dev server is a copy of the pre-production server.

This might be causing the Episerver login issue in my local??

If my windows credentials won't work for dev server DB, what are the other options I can try?

And yes, I tried the sample Alloy site in my local and it is working.

Please suggest how to resolve this issue. 

Jun 07, 2020 5:18

Your windows credentials will not work in this case so don't try that.

I think license is not an issue since you are only accessing the database.

The only option now you have that you can try login with any existing user account that is present in the database.

Or try creating new user account in that database.

And what about the question that I asked about connecting database from SSMS.

Jun 07, 2020 5:35

Hi Ravindra,

Yes, I can connect the Dev server's Episerver database from SSMS.

If I try creating a new user account in Episerver DB, Will I get the full access of the Episerver CMS dashboard including the site tree structure to create and edit the pages?

Jun 08, 2020 4:25

Yes, but make sure the user should have administrator access if you want full access

Jun 08, 2020 4:30

Hi Ravindra,

I will try this approach and let you know the update. Thank you so much for your support.

Jun 08, 2020 5:20

Hi Ravindra,

I got the new user account in DEV server db (Episerver Db), I tried login with my account credentials. Still, I am getting the same error.

The trust relationship between the primary domain and the trusted domain failed.

What could be the reason for this error?

Please suggest...!

Jun 29, 2020 23:03
This thread is locked and should be used for reference only.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.