SaaS CMS has officially launched! Learn more now.

404 trying to access Edit mode

Vote:
 

Hi! 
When I deploy my site (CMS 8.0) to an Azure Web App I get a 404 when I try to enter the edit mode. The modules-folder is included on publish and I've tried the suggestions in these posts without success
404-not-found-in-editadmin-mode (v 7.5)
404-when-trying-to-access-edit-mode (v 6.2)

It works fine in my local dev-environment but not in azure. Any other ideas what can cause the problem?

Thanks!
Oskar



#140867
Nov 02, 2015 14:27
Vote:
 

Hello Oskar

Is this a new build CMS 8 site or has it been upgraded from earlier versions?

David

#140886
Nov 02, 2015 20:41
Vote:
 

Hi David!

It's a new site.

Oskar

#140887
Nov 02, 2015 20:50
Vote:
 

Can you try publishing to a new IIS site on your local machine (or to a dev server) and see if you still get a 404?

#140891
Nov 02, 2015 23:23
Vote:
 

So locally the same site or working OK, when deployed to Azure - you get 404. If you compare folders (local->azure) any differences? Also you can access WebApp diagnostics (under Tools menu item) and see maybe something interesting could be found in episerver log files.

Also a pretty dumb question - but do hit correct edit ui link? I've seen that people sometimes trying to hit /cms instead of for example /episerver :)

#140925
Nov 03, 2015 23:05
Vote:
 

Hi guys!
Thanks for your replies, they both contributed to the solution :)
I solved the problem by cleaning the Web App "IIS" and publish again, it now works as it should :)

//Oskar

#140936
Nov 04, 2015 10:13
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.