SaaS CMS has officially launched! Learn more now.

404 when trying to access edit mode


I have an EPiServer 6 R2 site, which is developed and compiled locally on a development machine with Windows 7 and IIS 7.5 and SQL Server 2008 R2.

Deeployment to a new IIS site on my testmachine got me some troubles as it is running Windows Server 2003 with IIS 6 and SQL Server 2005, but finally I got it to work fine (as i can not upgrade it all at the moment unfortunately).

Now I want to deploy that same code to our production environment with same configuration and I get almost the same problem.

I can reach http://mysite/util/login.aspx but NOT reach http://mysite/epi/ui/cms/ - then I just get a 404 page?!

If I put up a test.aspx file (http://mysite/test.aspx) which is a regular ASPX-page and not a EPi template it works fine as well.

Paths is correct in episerver.config (uiUrl="~/epi/UI/CMS/" utilUrl="~/util/") and location-tags in Web.config as well. 


What I do not have is Default.aspx in the root directory, only kept default.htm that shows "Behind Every Great Web Site" etc....


Any idea what I am missing?


Jan 23, 2014 13:36

I vaguely remember having the problem that my virtual path to UI gave me 404:s, I believe there was a configuration fail in the corresponding location element a bit down in the config file. Something with the handlers. Not sure it's much help, but it's a straw.

Jan 23, 2014 14:03

Is it just edit mode you can't reach? Does the site load correctly when loading http://mysite/?

Jan 23, 2014 14:07

Actually when I had the same problem on my test site I made a new site in IIS called http://mytestsite2.

Now when that one actually works I wanted to rename it to correct http://mytestsite - so I did and now I get same error in test as I have in production!

So can it be related to the name of the site in some way? I now there are tblSiteConfig in database - do I need to manually update somethin when I rename site in IIS so that could also be the problem in production?

Jan 23, 2014 14:08

The IIS bindings need to be updated to correct url. Same goes for siteUrl in episerver.config.

Jan 23, 2014 14:10

I now got "scared" and renamed everything back again to http://mytestsite2 which means the sitename in IIS, wwwroot-folder-name, and also all settings in episerver.config etc.
So it all works again - BUT NOT reaching http://mytestsite2/epi/ui/cms ?!? (which worked before I started the renaming of things)

So something is really strange when I just wanted to rename it all back again and suddenly I can not reach edit/admin mode - but util/login.aspx works fine and also visiting a Url on the site.

Is there any relation that is done in IIS or in Episerver database when I do renaming?

Edited, Jan 23, 2014 14:16

I solved it!
As I already had rows in table tblSiteConfig with column siteId set to 'mysite' - and I knew it was unused - I just renamed them with an UPDATE to '__mysite'.

Then I renamed my site again and all references in episerver.config and EPiServerFrameWork.config and new rows were added to the table by application.

I still got 404 page when trying to access edit/admin mode - but after a while it just started to work. I guess due to EPiServer cache maybe?

Anyway, now it works after my site renaming.

Jan 23, 2014 14:58

I also sufferd from this error, but in my case the folder "\modules\_protected" where missing after the upgrade, and also the corresponding web.config elements for this folder where missing. 

Sep 29, 2014 13:15

Thanks Christian Lindeberg! I had the same problem after an update and sure enough, it was the "\modules\_protected" folder causing the error.

Nov 19, 2015 18:29
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.