Don't miss out Virtual Happy Hour this Friday (April 26).

Try our conversational search powered by Generative AI!

Display in navigation checkbox is gone

Vote:
 

Hi,

With our Development database the "Display in navigation" checkbox for content types has disappeared for all content types, across all sites.
Strange is, if the same codebase running on another database like Test and Int databases, the checkbox is there.
In the code the checkbox is never (deliberately) hidden. I tried to look for hacks in code for this property, but there is not any:
    public virtual bool VisibleInMenu

    {

      get => (bool) (this["PageVisibleInMenu"] ?? (object) false);

      set => this["PageVisibleInMenu"] = (object) value;

    }

Do you have any ideas how to track this down, how to get it back for that particular database?

I searched in the database for PageVisibleInMenu, but I could not find a way to hide/show it.

I found I can change the value in the database directly, but it is not a good solution on the long term.

Regards,

Zsolt

#247589
Edited, Jan 25, 2021 12:12
Praful Jangid - Jan 27, 2021 12:58
Can you check your logs to see if there is any error being logged? If so, can you paste in here your error?
Zsolt Nemeth - Jan 28, 2021 9:36
No error is logged in the server log, or anything unusual.
In browser console only the following warnings are logged, they look unrelated:
widgets.js:2 Observable store detected, but no sort order specified. You may experience quirks when adding/updating items. These can be resolved by setting a sort order on the list or grid.
_updateNotifyHandle @ widgets.js:2
DevTools failed to load SourceMap: Could not load content for http://localhost:61977/EPiServer/EPiServer.Cms.TinyMce/2.7.1/ClientResources/tinymce/skins/lightgray/skin.min.css.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE
Vote:
 

I can suggest following to try

1 - Restart IIS website - I assume you already did this, its Dev environment 

2 - Go to CMS -> Admin -> Content-Type -> Select any page type - Try to add property PageVisibleInMenu. it should give you an error (similar to the field already there etc) but it will also force the interface to sync with the database. I use this option when I deploy the latest release but for some reason, my properties are not appearing in page type.

#248173
Feb 04, 2021 22:48
Vote:
 

Are you seeing this type of warning when you select your content type (page/block type)? (CMS -> Admin -> Content Type)

If yes, then follow these solutions

https://world.episerver.com/forum/legacy-forums/Episerver-7-CMS/Thread-Container/2013/10/Changes-in-the-model-for-this-page-type-were-ignored-because-its-version/

https://world.episerver.com/blogs/ollie-philpott/dates/2019/2/common-errors-when-developing/

And then check if you properties are updating or not.

#248200
Feb 05, 2021 7:01
Vote:
 

I am using IIS Express - restarting does not help.

If I try to add property 'PageVisibleInMenu' to any of these pages which I have, I get an error, that it is reserved for metadata, it is not possible. If I add a new field with any other name, it does not make a difference.

The issue happens on all pages. Model and database versions are the same, there is no warning for this kind of issue. If I add new properties in code, they are being displayed correctly.

#248201
Edited, Feb 05, 2021 8:08
Vote:
 

I will contact support with this issue.

#248502
Feb 11, 2021 15:03
Praful Jangid - Feb 11, 2021 16:38
That seems only possible remaining solution. :)
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.