Try our conversational search powered by Generative AI!

ClassFactory not initialized

Hi! I'm trying to move my CMS5 installtion from my local XP machine to Win2003 server. I installed a new site using EpiServer Manager and then copied in my page files and .dlls. The problem I'm having is that I can't get the site running due to the following unhandled exception: ClassFactory not initialized Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. Exception Details: EPiServer.BaseLibrary.ClassFactoryException: ClassFactory not initialized Source Error: An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below. Stack Trace: [ClassFactoryException: ClassFactory not initialized] EPiServer.BaseLibrary.ClassFactory.get_Instance() +126 EPiServer.BaseLibrary.Context.get_Repository() +24 EPiServer.WorkflowFoundation.StorageProviders.ObjectStoreStorageProvider.VerifyCommonSchemas() +15 EPiServer.WorkflowFoundation.AspNetWorkflowManager.get_StorageProvider() +44 EPiServer.WorkflowFoundation.AspNetWorkflowManager.Initialize(Boolean lazyLoading) +563 EPiServer.WorkflowFoundation.WorkflowSystem.Init(HttpApplication context) +297 System.Web.HttpApplication.InitModules() +267 System.Web.HttpApplication.InitInternal(HttpContext context, HttpApplicationState state, MethodInfo[] handlers) +1251 System.Web.HttpApplicationFactory.GetNormalApplicationInstance(HttpContext context) +243 System.Web.HttpApplicationFactory.GetApplicationInstance(HttpContext context) +106 System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr) +214 -------------------------------------------------------------------------------- Version Information: Microsoft .NET Framework Version:2.0.50727.42; ASP.NET Version:2.0.50727.42 Any help will be much appreciated. Best regards, Jonas
Oct 15, 2007 15:19
I've got the same problem. Situation: Trying to convert my 4.61 site to CMS. I installed CMS and moved my existing code into this site. I haven't investigated much yet.
Oct 21, 2007 21:13
Any answer/solution to this? Got the same problem.
Feb 26, 2008 13:01

I had exactly the same error log. There was a major error in my Global.asax/cs. Perhaps you should check for something there?

Anyway, your error is produced before any page is executed...

Edited, Aug 26, 2008 20:59

I get a similar exception when trying to run the PublicTemplates project in VS2008. Has anyone tried to do this? It compiles/builds ok but i get a "ClassFactoryException: ClassFactory not initialized" when I try to run the project.

Nov 05, 2008 12:11

Nina, I got this error when I tried to run the project in the ASP.NET Development Server but the web.config was configured for IIS 7 (on Vista). So, if this is the case, just change the project settings to point to the IIS site instead.


Nov 05, 2008 13:09

I have had similar problems: I'm trying to run an existing R2 site with IIS 7 on vista. I read that I need to set the app pool to run as classic? which i did.


i get this error now:

seems lik a VPP err but have checed that the paths are correct and that IIS_IUSRS is setup to access the folders.? any ideas please

[TypeInitializationException: The type initializer for 'EPiServer.DataAbstraction.UnifiedPathInfo' threw an exception.]
   at EPiServer.DataAbstraction.UnifiedPathInfo.Load(String path)
   at EPiServer.FileSystem.DefaultAccessControlList..ctor(String path)
   at EPiServer.Web.Hosting.DirectoryAccessControl..ctor(String virtualPath)
   at EPiServer.Web.Hosting.UnifiedDirectory.get_DirectoryAC()
   at EPiServer.Web.Hosting.UnifiedDirectory.QueryAccess()
   at EPiServer.Web.Hosting.UnifiedDirectory.QueryDistinctAccess(AccessLevel access)
   at EPiServer.Web.Hosting.VirtualPathVersioningProvider.GetDirectory(String virtualPath)
   at EPiServer.Web.Hosting.VirtualPathHandler.InitializeProviders(ProviderSettingsCollection providers)
   at EPiServer.Web.InitializationModule.InitializeVirtualPathProviders(VirtualPathElement vpElement)
   at EPiServer.Web.InitializationModule.Initialize(EPiServerSection config, Settings settings, ConnectionStringSettingsCollection connectionStringSettings)
   at EPiServer.Web.InitializationModule.StaticInitialization()
   at EPiServer.Web.InitializationModule.Application_BeginRequest(Object sender, EventArgs e)
   at System.Web.HttpApplication.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
   at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

[Inner exception TypeInitializationException: The type initializer for 'EPiServer.CacheManager' threw an exception.]
   at EPiServer.StaticCacheKey.EnsureKey()
   at EPiServer.StaticCacheKey..ctor(String keyName)
   at EPiServer.DataAbstraction.UnifiedPathInfo..cctor()

Jul 16, 2009 0:20
Jul 16, 2009 9:28

For us this error was caused using IIS7 and EPiServer 5 R2 as the Application Pool for the website in IIS was set in the default mode of 'Integrated'.

To fix, find your application pool in IIS Manager and change the Managed Pipeline to 'Classic'

Dec 29, 2011 12:32
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.