Try our conversational search powered by Generative AI!

Form data not sent to Pardot


Hello guys,

I'm trying to connect episerver to pardot but i'm facing some issues while sending data. I managed to connect them (I can see prospect fields in the mappings tab) but when submiting the form there is nothing changed in pardot. Do I miss something?

I did everything described in the marketing-automation/pardot addon page.

For example I tried to create a form containing a textbox mapped to email field, a textbox mapped to website of the prospect and a submit button. If I add a new email, the prospect is not created. If I add an existing email, the prospect is not updated. The form submissions are stored in episerver but not synced with Pardot.

Nov 13, 2018 11:33

Hi Alex,

I have just tested with our test account and it still works. I create fresh Alloy site, install nuget packages and go to Admin page to configure settings for Pardot Connector. Then I created a form mapping to Pardot's fields, submit the form. That's all I did.

Open the log file to see if any errors occurred.

If there was no errors, please check your account information. You may need help from Pardot team to verify that your account is still valid (even if you can login to Pardot site, the account some show does not work at all).

Edited, Nov 14, 2018 9:54

Hi Tran,

Thanks for the quick reply. Just to be sure, by mapping you mean going to the mapping tab in form level and select the Prospect table then go to the field level (text-box for example) and in the mapping tab select the property from the Prospect table? Also, I belive the submit is just a simple button, not linked/mapped to anything.

I can try to test with another account. I was afraid to not miss any configs.

Nov 14, 2018 10:01

Hi Alex,

Yes, according to your description, you're going to the right way :)

We have two test accounts (both can be used to login to Pardot site) but one is not working anymore, there's no data when we submit the form. I may need help from Pardot team also :)

Edited, Nov 14, 2018 10:07

Thanks for the feedback. I'll check also with Pardot team to see what's happening.

Nov 14, 2018 10:34

Aaaand i'm back.

I tried to create a new alloy website and test it with several admin accounts without success. I contacted Pardot support and they said that non-native controller are out of scope for their support. Instead, they sent me back to EpiServer support. So, right now my connection is partially working but the data is not sent and I tried everything I had.

Nov 21, 2018 9:59

Do you turn off the session state ?

We still got no clue about the issue.

Nov 22, 2018 10:02


I manage to reproduce this error on alloy. 

I setup the error logging to record everything and managed to get an error message.

The remote server returned an error: (400) Bad Request.

Episerver sends the following request. What's wrong here is that "id" should be "email".{userKey}&api_key={apiKey}

I manage to succecesfully send a form with some hacking and after that everything works fine(Seems like the id is cached in browser). But if try to send a new form in incognitor then i get the same error again. 

This looks like a bug in episerver to me.

Edited, Nov 30, 2018 13:22

I received a reply from Episerver and they confirm that it is a bug and it will be fixed within version 4.1.0 of Episerver.Marketing.Connector.Pardot 

Dec 05, 2018 11:28
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.