Concurrency violation: the UpdateCommand affected 0 of the expected 1 records



Over the past coulple of days we have expereinced this error message. The first time a developer received it it only affected them and it lasted almost 2 hours before seemingly resolving itself. We tried rebuilding, cleaning, restarting, everything we could think of. When it seemingly resolved it self the developer got the latest code from Git but we think it was a coincidence.

The next day it happened to a different developer working on the same site but unrelated code. As of writing this the issue is still unresolved. They are unable to access any page on the site locally on their dev machine accessing a central SQL database. We have tried replicating all the steps the previous developer tried but to no avail.

Can anyone please help?



Jun 18, 2014 1:20

I am experiencing this issue on an import. api...   the preimport removes a product as a parent from the variant, then the import adds a product to the variant. I am not sure if that logic is related, but this is very random and there isn't enough information to determine the cause of the problem.

Feb 14, 2022 14:30
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.