Try our conversational search powered by Generative AI!

Default EPiServer projects in Visual Studio don't work


I have installed the EPiServer CMS Visual Studio Extension (version

Then I've tried to create a new Episerver project: File->New->Project...->EPiServer->EPiServer Web Site. There I could choose one of three options: Empty, Alloy (MVC), Alloy (WebForms). For all these 3 types of projects I've got the same result - HTTP Error 500.19 - that points to web config. The error is the same for IIS and Visual Studio Development Server.

The Alloy site installed by EPiServer Deployment Server (ver. 7.5.394.2) works fine and it seems that it has completely different configuration

This fix helps only with one issure, however the site would be still broken.

My Environment: Windows 8.1 Enterprise, Visual Studio 2012 Premium, IIS 8.5

Sep 18, 2014 12:18
Does anybody faced the same problem? Or do these projects run fine without any "dances" with the configs, etc.
Sep 22, 2014 14:09

Hi @Boris Sokolov use this one tutorial

Oct 08, 2014 16:33

Hi Oleg, I don't have any idea, how this tutorial could fix the issue.

I've removed the Episerver Deplyment Center and the situation started to look better.

Also there is a big problem in the Episerver Extension - it doesn't throw you any errors during the template site creation. And if you have some local issues such as lack of permissions of other troubles - then you could get a sample site with broken or missing configs, broken DataBase and so on.

Oct 08, 2014 22:57

The differens is that deployment center is using local IIS and the plugin is using IIS Express.

You can try to manually create a IIS-site that points to the folder where the extension has created the site and see if that works.

By the error it seems like you have a broken applicationhost.config for your IIS Express (

Oct 09, 2014 10:57

Make sure you have LocalDB for sql installed as well. The extensions use localdb for serving db. 

Oct 11, 2014 13:20

The issue seems to be fixed for me, but it still not clear where it comes from.

  • I had local DB installed and Deployment Center's Alloy worked just fine. Also the error was not caused by the broken or missing DB.
  • I don't think that the problem could be caused by the IIS/IIS Express issue. The site with a broken config would not run both on IIS and IIS Express.

Currently I have:

  • Removed the Deployment Center, re-installed the VS extension - and the VS extension started to produce correct config files
  • I've got some other issues because of the folder permissions - fixed them - and the site works just fine now.
Oct 11, 2014 13:55
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.