Episerver Search Index not found


I am relatively new to Episerver so please forgive me for any newbie mistakes.

I am implementing search on a multisite setup.  The search works in dev just fine but once promoted out to production I get "0" results.  I gone through the following troubleshooting steps:

1) URL of indexingservice is correct ***

2) MultiSiteBindingsEnabled = true

3) appDatapath\Index *appears* correct (more on this)

4) Testing the service returns "Endpoint not found"

5) Testing the service update returns "Method not allowed"

Here is where it gets weird,

6) Rerun Index command *appears* to work.

But when I go to the folder location I expect the index to be (AppData/index/main/...) I do not see them.  There were indices there that I removed as a test to arrive at this point.  So my question is this, how do I verify where the index command is supposed to be putting the indices?  Or am I missing something completely here?

Any help would be greatly appreciated.


Nov 13, 2015 18:30

Take a look at the episerver log.  What does it say when you go to re-index.  There should be some error log in there stating the issue.

there is a place to re-run the index   /episerver/cms/admin/indexcontent.aspx

Nov 13, 2015 18:45


Thanks for reminding me about logging.  So with that enabled I was able to see that the URL for the IndexingService was not able to connect.  Turns our there is a firewall rule that is causing the problem.  What I am now looking for is a port or protocol that I can use to help setup a proper rule to allow connections to the server so it can get to the IndexingService.

Any ideas?


Nov 13, 2015 21:39

Try adding the ip address of your filewall to the ip address or specify the allowed up.  The port you shouldn't have to worry about but if it is an issue, add a host entry to the host file   xxxx.local and then use that for the indexing service so it doesn't need to go out through your firewall.

Nov 13, 2015 21:50

So I tried the host file edit and that only half worked.  The site would resolve when attempting to load from the server itself (RDP to the server and load a browser), but when trying to run search from 'outside'  still gives me an Unable to connect error in the log file.

What is compounding this is the fact that I deleted the indices that were there so I first need to get an index built so if I do that then I also fix search since it appears that both use the IndexingService to do their thing.

I will add the IP of the firewall to see if that works.


Nov 13, 2015 21:59

What about a relative path to the IndexService instead of an absolute URL?  Is there anything that Epi is doing that would cause this not to work?


Nov 13, 2015 22:27

* Update *

This appears to be a server problem though one I am not easily able to identify.  For whatever reason, the server is unable to see itself so the reference to the IndexService is yeilding the "unable to connect" error in the log file.  I hoping I'll be able to get this resolved with the network team soon.


Nov 16, 2015 22:13
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.