Try our conversational search powered by Generative AI!

Replacement Language - previewing during content load



One of the documented use-cases for Repalcement Lagauge settings is...

... when you have started to translate content on your website, but do not want to have mixed languages until translation is completed. When translation is ready, you simply remove the replacement language.

I have configured a replacement language (Portuguese > English) on the website start (home) node. All other pages inherit language settings from this page. My editors have now begun to translate English pages to Portuguese.

How can my editors preview the changes they are making as they progress with this translation project? All translated pages are shown in English with the message "For visitors, this page is replaced by a version in English." 

Using the Preview function merely renders the page in English.

Is it possible to preview the page as Portuguese? Seems crazy that they cannot!



Jan 28, 2016 12:38


I think that you can see Protugese version in edit mode - On-page edit view. And you will not able to see portugese version in view mode when replacement language is enabled. The view mode is used to end users.

Jan 28, 2016 13:33

Edit mode only shows the English version when in Portuguese... here's the Alloy site exhibiting the same behaviour - English content is shown in edit-mode, not Japanese which is configured with a replacement language set to English:

Alloy edit mode - Japanese language


and the url for reference, note the language parameters: http://localhost:29678/EPiServer/CMS/?language=ja#viewsetting=viewlanguage:///ja&context=epi.cms.contentdata:///5

Edit - fixed image

Edited, Jan 28, 2016 15:14


I did similar test. Run Alloy demo with newest EPiServer (9.6.1).

In admin mode I added Portugese language.

Then in edit mode I enabled language on Root node level.

Next on Root level set the replacement language from English to Portugese.

On Start page I set inheritance from Root enabled (many times I forgot about this step)

I clicked Sites and switch language to Portugese - none of the pages was trannslated of course.

I selected Alloy Track page and clicked Translate button. I changed name to Alloy Track Pt, and set Unique selling points property (because it was required)

The Alloy Track Pt appeared...

The Url in portugese edit mode is: http://localhost:58359/EPiServer/Cms/#viewsetting=viewlanguage:///pt-BR&context=epi.cms.contentdata:///9


Edited, Jan 28, 2016 21:13

Hi, thanks for spending the time to research. My language settings only existed on the home node. I tried moving them to the root then inheriting home language settings from the root but still the same issue.

It seems if the language settings are applied to the home node first (as in my case) then even moving them up to the root node the issue is not resolved. I guess it must be a bug in version 8, which we're using.

I'll need to investigate upgrading to see if this is resolved :/


Jan 29, 2016 14:54
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.