Try our conversational search powered by Generative AI!

How to log in to Alloy sample site?


Hi all

I installed the Alloy WebForms sample site, but I can't log in to the "admin" area. Yes, I have tried my Windows credentials, and they do not work.

This is on a Windows Server 2012. I tried the credentials I logged in with as well as another valid Active Directory account, but I can't get in. Says "login failed" for the currently-logged-in user and just reloads the login box with no additional messages for the not-logged-in AD user.


Dec 20, 2016 20:02

Hi, Yukon,

Normally, I go to Local Users and Groups under Computer Management and create an Epi user, then assign him to Administrators. This should give you a user you can log in with.

The fact that it reloads the login box with no error messages means that you are authenticated, but not authorized. Check if this user you are logging in with is either a member of Administrators group or if this group is named differently on the server, ex. CompanyAdmins, then you can add that group in virtual roles next to Administrators and WebAdmins.


Dec 21, 2016 12:07

Hi Marija,
Thank you for the advice. I am trying to follow the Episerver documentation to set up a sample website. Can you please provide a link to the documentation about how to set up the users? (If you know it). I am just concerned that it doesn't seem to be working as documented and wondering what I did wrong. Thanks!

Jan 17, 2017 16:06

Hi Yukon

Here is a link to another thread where someone had a similar issue here

The key is that the Windows user must be a local admin of the machine you are running EPi on.



Jan 19, 2017 7:30
Jan 19, 2017 9:23

If you have chrome on machine try to use incognito mode, then check your logs first. Then check web.config to make sure multiplex and AD provider is there

Jan 19, 2017 11:44

Hi everyone, thanks for the replies. 

I checked event viewer, no errors. I checked Episerver error log file, it was empty. The user is a member of Administrators and also Users and is currently logged in to the server (Server 2012). The user has "Full Control" of the folder where Episerver is installed. I tried checking the web.config and it has multiplexing role. This is a plain Alloy website (WebForms version) that I just installed and the only thing I changed was I put the database on SQL Server (and not LocalDB).

I talked with someone at Episerver and he told me I had to make a new user in the Control Panel/Users and Groups and use that user. I created a new local user (not domain user) and was finally able to log in.

I am boggled that people have had to write code just to log in to a fresh install of a sample site. I am evaluating CMSes right now and I have never heard of this.

I wish the method of how to log in (have to create a new local user) was in the documentation. All it says is to log in with your Windows credentials but that doesn't seem work when the computer is connected to a domain, apparently (as I imagine most enterprise computers would be). I hope Episerver decides to update their documentation or improve their product.

Jan 19, 2017 17:44
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.