SaaS CMS has officially launched! Learn more now.

WebSocket connection failed - HTTP Authentication failed

Vote:
 

Hi

It looks like WebSocket works in browser ie, but not in chrome.

When i start /episerver i get this error message in console.

WebSocket connection to 'ws://edit/EPiServer/Shell/socket/endpoint/' failed: HTTP Authentication failed; no valid credentials available (widgets.js:2)

I also get a dialog message

Real-time Updates

A Real-time connection could not be established with the server. This may be caused...................................

Does anybody know how to fix this.

This works, but i do not want to do that.

   

#151641
Aug 02, 2016 12:50
Vote:
 

Forgot to add that i am using windows authentication on the edit server.

#151642
Aug 02, 2016 12:53
Vote:
 

I think the issue here is that Chrome cache the old credentials and uses the same while requesting WebSocket endpoint. To confirm this you can open a new incognito window (a private window on FF) and browse to the edit page. 

#151675
Aug 03, 2016 16:03
Vote:
 

Hi Khurram

Thanks for your input. I get the same error in incognito window.

#151691
Aug 04, 2016 8:58
Vote:
 

It works if i change to forms authentication.

#151693
Aug 04, 2016 9:43
Vote:
 

There was a change in a recent EPiServer which means if running through IIS you need to enable WebSocket Protocol in windows features, it would be worth checking this as I remember there was a popup error related to WebSockets when you don't have it enabled.

#151706
Aug 04, 2016 11:36
Vote:
 

WebSocket protocol is enabled. It works in ie and firefox. And it work in chrome if i use forms authentication.

#151711
Aug 04, 2016 11:57
Vote:
 

Did you find a solution for Windows authentication in chrome?

#161159
Oct 06, 2016 15:40
Vote:
 

No. It is a chrome issue. Chrome will eventually support windows authentication for websockets.

#161163
Edited, Oct 06, 2016 15:51
Vote:
 

Is this still an issue with Chrome? We're getting the same error when using windows authentication.

#194680
Jun 28, 2018 9:38
Vote:
 

Yes. I have not seen any progress on this.

#194683
Jun 28, 2018 10:23
Vote:
 

Windows Authentication for WebSockets was not correctly performed by the Chrome when you logged this bug.
You take it as a bug in Chrome or "not supported feature yet" in Chrome, it has nothing to do with EpiServer implementation.  

The progress for this bug/feature can be monitered here https://bugs.chromium.org/p/chromium/issues/detail?id=423609 I'm not sure about the latest development but as soon as this bug is fixed in Chrome, your EpiServer deployment will start working with WebSockets.

#194684
Jun 28, 2018 10:34
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.