SaaS CMS has officially launched! Learn more now.

Shortcut default property options are shown as integers (-1,0,1, etc)

Vote:
 

Episerver CMS 10.9.1.0

Im facing a wierd problem with the default property "Shortcut" under the "Settings" tab on all pages.

When selecting "manage shortcut", previously, the options for the property "Shortcut type" would be:

  • Link to this page
  • Shortcut to page in EPiServer CMS
  • Fetch data from page in EPiServer CMS
  • Link to page on another website
  • No link, only text

Instead now i have behaviour as if the "Shortcut type" property was of type integer. I can choose any number instead of the 5 options listed above. However if i chose e.g "4" it will correctly map to the option above that would be on that index.

Anyone have any idea? I read about the Shortcut property here: http://webhelp.episerver.com/latest/cms-edit/all-properties-view.htm
and as far as i am concerned i have no controll over what options should be listed for the property.

Thanks!


#185235
Nov 13, 2017 11:40
Vote:
 

The ShortcutType is an enum (generally stored as an integer).

You can find the different enum values here: http://world.episerver.com/documentation/Class-library/?documentId=cms/10/5A6DD5DB

Normal = 0
Shortcut = 1
External = 2
Inactive = 3
FetchData = 4

#185239
Nov 13, 2017 13:48
Vote:
 

So my question is Alf, why does my editor interface not show those options? On our prod server, we have 5 options which are strings such as "Shortcut to Page in Episerver CMS".

Instead it lets me select an integer.

#185240
Nov 13, 2017 13:57
Vote:
 

Do you mean that when you perform the following steps

  • Access Episerver edit mode
  • Selects a page
  • Goes to "All Properties" mode
  • Clicks on the tab "Settings"
  • Clicks "Manage" for the property "Shortcut"
  • Fold out the drop down "Shortcut type"

That the dropdown does not show the options?

No shortcut
Shortcut to another content item
Shortcut to page on another website
No shortcut, display text only
Fetch content from another content item

#185242
Nov 13, 2017 14:01
Vote:
 

Yes, exactly. Sorry for not being clear. Instead of these 5 options i can set it to any integer. Setting it to 0 will "fold out" additional fields, as if i would have set it to "No shortcut".

(So functionality technically works but its not very user-friendly)

#185243
Nov 13, 2017 14:06
Vote:
 

Sounds like translations aren't displayed properly.

What languages are you running on your website and what languages are you using for the Episerver interface?

#185244
Nov 13, 2017 14:08
Vote:
 

Running Swedish and English. Tried both english and swedish in the epi interface, same result.

#185245
Nov 13, 2017 14:13
Vote:
 

We were also experiencing this issue a little while ago on a client but it's no longer occuring checking on CMS 10.10.4 which we have upgraded to.

#185251
Nov 13, 2017 15:46
Vote:
 

Scott's right..this has been resolved in EPiServer.CMS.UI 10.9.6

The bug raised can be found here: http://world.episerver.com/support/Bug-list/bug/CMS-7699

#185261
Nov 13, 2017 17:59
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.