Need help: trying to fix existing links in database.


Having an issue, existing entries for a page type have a multi-select link field where existing links just use the link name/text field.    The external link is blank and get entered in as http://.   This was kind of a hack.. not sure the reasoning behind this.

I guess that was acceptable awhile ago, but unfortunately now the CMS is in a state where it will no longer allow entries of this type.

I get this error every time I make an edit:

I would like to correct these entries to put a valid link to bypass this error, but I can only enter one entry at a time then it will verify the entire entry and discard my changes.    Any way to fix this?   I tried looking in the database but it doesn't appear that changes to tblContentProperty in the LongString field affect the pages.   Changes in the database do not show in the CMS.   However ironically changes in the CMS, I see them automatically in the database.

Any help would be appreciated.

Feb 07, 2017 0:00

EPiServer caches data to improve performance. Have you tried restarting the app pool?

Feb 07, 2017 2:49

Stopped and restarted the App Pool and also the website, I still see the old values in the CMS when I try and edit one of the links.    I know I'm in the right database, because entries I make to a new entry using the CMS - there I see the new values in the tblContentProperty table in the LongString field.    The problem is older existing entries.    I'm not too familiar with the db schema, are the entries stored in another db table that I should be updating as well?


Feb 07, 2017 16:41

Hi Brian,

How about tblWorkContentProperty table? And app pool restart after that to clear the cache.

Btw, isn't it easier to use ContentRepository to change the values and republish the page?

Feb 07, 2017 22:31
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.