Try our conversational search powered by Generative AI!

The store was queried with a [string] but the entity id is a [undefined]


When loading a page in OnPageEdit I first see a warning in the console: 

"Observable store detected, but no sort order specified. You may experience quirks when adding/updating items.  These can be resolved by setting a sort order on the list or grid."

If I try to edit any of the blocks, I get lots of "The store was queried with a [string] but the entity id is a [undefined]" errors.

The error is reported by widgets.js inside Episerver Shell ClientResources folder (version 10.7.1).

Does anybody know what is causing this?

Apr 03, 2017 11:26

It was an issue in previous versions. Not sure if it's been fixed yet.


Apr 04, 2017 5:36


Apr 04, 2017 5:44

Add <clientResources debug="true" /> to web.config, in the episerver.framework section, and you should get some more information to see what's causing this

Apr 04, 2017 8:56

Nice tip, PM!

The error is reported from _StoreMixin.js which is located in /Shell/ 

The warning message is now a bit more detailed:

"Observable store detected, but no sort order specified. You may experience quirks when adding/updating items.  These can be resolved by setting a sort order on the list or grid."

The error message "The store was queried with a [string] but the entity id is a [undefined]" comes from Patchable.js (also located inside Episerver Shell)

Apr 04, 2017 9:08

Just a wild guess here, but is you "versions gadget" open by any chance?

Apr 04, 2017 9:36

No, the versions gadget is not open.

Apr 06, 2017 11:31

Tried to implement "Filtered display options" based on on a latest episerver (10.7)

Now, when pressing the menu on the block where i can choose to edit the block or change display option i get the same error message, "The store was queried with a [string] but the entity id is a [undefined]". This seems to just be logged in the console, but it is actually working. Any tip?

Apr 12, 2017 9:21

Did you manage to get rid of this issue? I'm facing it and I don't know where to start. Error in console leads to "epi/shell/store/Patchable". The outcome is that I have a problem with structuring media and blocks:

May 30, 2017 17:59

Having an empty ContentReference as the root folder for the descriptor displayed this console error for myself, couldn't find a solution to resolving this without actually giving the root a content reference 

Oct 04, 2017 12:45

Have you guys experiencing any faulty behaviour in Epi CMS when that error occurs? I get that same error, and I'm having problem with that the page does not load when clicking on its node in the left pane tree in editing mode.

Did you get rid of the warning message Mari?

Mar 21, 2018 13:41

I had the same issue with the error message and same behavior as Piotr.

I have a multisite and have enabled "Use site-specific assets" in Admin mode and the problem was only on one of the sites.

I upgraded to the latest version as of today, 11.11, but the error was still there.

The solution to get rid of it was to uncheck the box, save and then check it again and save.. Magically the error is now gone :).

I have a feeling that it has been fixed in the latest version and the remaining error was result of some cache related.. 

I didnt had to do the fix in my other enviroments. It just worked after the upgrade. 

Edited, Jan 08, 2019 13:56

Lately we found ourselves in a similar situation like Piotr and Pawel. For us, the error only appeared when logging in with a role lower than "Admin". The trick with (un)ticking the "site specific assets" worked for us, too, but I'd like to mention that this was only a feasible option because there were next to no site specific assets in the affected project. It seems that disabling the option automatically removed any content below the node. You wouldn't want that if your site made heavy use of the "for this site" assets (or you would have to find a way to retain/restore them).

Aug 28, 2019 16:53

Just wanted to say i got this same issue after adding a media type to handle svg images. I follwoed what Pawel and Philipp suggested (uncheck 'use site specific assets') but initially it didn't work. however, after i restarted the web app everything is working correctly. So if you have the same issue try a restart too.

Dec 08, 2020 9:50

For "Filtered display options" based on on a latest episerver (10.7)

I had the same error and I solved it changing the format of response of the RestStore Class

public class SupportedDisplayOptionsStore : RestControllerBase
	private readonly IContentLoader _contentLoader;
	private readonly DisplayOptions _displayOptions;

	public SupportedDisplayOptionsStore(IContentLoader contentLoader,
										DisplayOptions displayOptions)
		if (contentLoader == null) throw new ArgumentNullException("contentLoader");
		if (displayOptions == null) throw new ArgumentNullException("displayOptions");
		_contentLoader = contentLoader;
		_displayOptions = displayOptions;

	public RestResultBase Get(ContentReference id)
		IContent content;

		if (!_contentLoader.TryGet(id, out content))
			return Default(id);

		var specialRenderingContent = content as ISupportRenderingContent;

		if (specialRenderingContent != null)
			var supportedDisplayOptions =
					.Where(x => specialRenderingContent.SupportedRenderingTags.Contains(x.Tag, StringComparer.CurrentCultureIgnoreCase));

			return Rest(new SupportedResultModel(id, supportedDisplayOptions));

		// Default to all display options.
		return Default(id);

	private RestResultBase Default(ContentReference id)
		return Rest(new SupportedResultModel(id, _displayOptions));

	internal class SupportedResultModel
		public string id { get; }

		public IEnumerable<string> options { get; }

		public SupportedResultModel(ContentReference _contentLink = null, System.Collections.Generic.IEnumerable<DisplayOption> _options = null)
			id = _contentLink?.ID.ToString() ?? "-1";
			options = _options?.Select(x => x.Id);
Sep 10, 2021 20:25


we recently started seeing this error in the console. Every time admins try to enter data, we are seeing this error in the console also we are seeing Offlice Can't save error on top of the edit page. Tuned on the logs but there is nothig in the logs other this the console error in the browser. 

Anyhelp would be greatly appreciated.

Thank You,


Mar 24, 2022 4:33

Found my way here troubleshooting. Setting clientResources debug="true" in my case shows this:

Error: Tried to register widget with id==iiiDeleteButton but that id is already registered
    add h/epi/Shell/11.36.4/ClientResources/epi/shell/widgets.js:2
    create /epi/Shell/11.36.4/ClientResources/epi/shell/widgets.js:2
    _1a5 Dojo
    create /epi/Shell/11.36.4/ClientResources/epi/shell/widgets.js:2
    postscript /epi/Shell/11.36.4/ClientResources/epi/shell/widgets.js:2
    Dojo 3
    updateView /epi/EPiCode.InspectInIndex/1.5.1/ClientResources/Scripts/InspectInIndexView.js:63
Jan 16, 2023 10:35

I suggest adding an issue here:

Jan 16, 2023 10:56
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.