SaaS CMS has officially launched! Learn more now.

How to set editor access right for a specific language of a site



I would like to set access right for an editor group so that they have ONLY access to read/create/change/delete/publich a specific language branch. 

If I set as WedEditor, the user have access to all languages. How shall I do to solve this?



Nov 23, 2018 13:56

Hello ChiChing

You can manage this in admin mode by configuring the Access Level for a langauge:


Nov 23, 2018 16:16

Hi David!

Yes, I created a gorup calls "WebEditors_Finland" and added this group to swedish lanuage branch in"Mange Website language".

When I login, I couldn't edit any page in the Finnish site.

Did I miss anything?



Edited, Nov 23, 2018 16:35

Un-select the 'Everyone' checkbox so that only users in the 'WebEditors_Finland' group/role can create content in Finnish (if you have Everyone in the language selected it means everyone can create content in that langugae as long as they have correct access rights for the content).

You are speaking about swedish editors but images have the finnish editors?

Anyways that setting only changes who can create content in that language. You need to have correct access rights also for content creation, editing, deleting, admin etc.

So if you now have just created group 'WebEditors_Finland' and created a new user (and assigned this new user to 'WebEditors_Finland' and 'WebEditors' (the Episerver default group to access edit mode)). The 'WebEditors' group should be only used to control access to the edit mode and you should have for example 'SitePublishers' group which you use to set access rights to content. So in your case it could be that the user has now access to edit mode, could create finnish content but don't actually have access rights to actually create content.

So at simplest scenario you would have a group called 'SitePublishers' created. In admin view 'Config' tab -> 'Set Access rights'. Select the site start node in the access rights tree, un-check 'Inherit settings from parent item', click 'Add Users/Groups' button. Search for 'Groups' and from the list select 'SitePublishers' (move it to the 'Add' list) and click OK. Then on the set access rights view, select all the checkboxes for 'SitePublishers' row (read, create, change, delete, etc) basically giving this group full editing rights for the content (access rights are explained here). Now users belonging to this group can edit the content and the group(s) added to language grants access to a language.

Edited, Nov 23, 2018 22:00

Hi Chiching 

Have you enabled Finnish for editing in the CMS. See "Enabling a language for editing in CMS" here: 


Nov 24, 2018 18:32

Thanks guys!

I did what Antti Alasvuo suggested and it works. 

Dec 04, 2018 10:00
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.