Try our conversational search powered by Generative AI!

Visual studio extension issue vs2017 latest release


episerver visual studio extension does not work 

with latest lelease  of vs2017 15.6.0 or 15.6.1

Mar 11, 2018 8:33

Having the same issue.

  • VS2017 15.6.1
  • Episerver VS extension

To clarify a bit, creating a new Episerver site works but not the Alloy templates. Alloy templates gives error that trying to use .net framework 4.5

Visual Studio UI for new project has changed to show the .net framwork selection in the lower left corner but this is not visible when creating Episerver site using the extension.

The Alloy template doesn't use the last selected framework but the Episerver site uses the last selected framework.

For example create empty MVC web site using framework 4.6.1 and then create Episerver site to the same solution (Episerver site uses framework 4.6.1)

Add another MVC empty site to the solution but use framework 4.7.1.

Then add another Episerver site to the solution and this site now uses 4.7.1 (remember the selection made last time when creating MVC site)


- uninstall and reinstall of the Episerver VS extension fixed the issue (there still isn't the option to choose the framework but now it honors the last selected framework)

Edited, Mar 11, 2018 21:17


Creating a .netframework project before creating episerver project which picked up the last saved .net framework version and it being 4.7.1, it worked.

But there is no way to select .net framework version while creaing episerver project which was there upto VS2017 v 15.5

Mar 12, 2018 8:59

Creating independently Alloy template project has the same issue but creating this as a second project in a solution having an MVC project works.

Mar 12, 2018 9:06

I have the same issue, and I've tried following the descriptions here, but so far no luck... I'm not able to get any of the Epsierver projects to install correctly, they all give me the error "Could not install package 'EPiServer.CMS.Core 11.3.4'. You are trying to install this package into a project that targets '.NETFramework,Version=v4.5'..."

See also:

Mar 21, 2018 8:59

Please follow the steps below:

  1. Create an MVC project and give the solution the name you want.Please select dotnet framework version you want which has to be the latest version.
  2. Then add episerver project to the solution.
  3. Finally remove the MVC project from the solution.

This will work then as the episerver project will pick up the correct version or you have the choice to change it.

Mar 31, 2018 19:06

can confirm that with no reinstall everything works as expected in VS 15.6.4. epi site created in empty solution uses 4.6.1

Apr 02, 2018 12:46

That is a better solution. But I hope there will be an upgrade soon. 

I tried with vs2017 preview release 15.7 preview2 and it works fine as before

Apr 02, 2018 15:08

Here's a simple solution that worked for me. Start out like you're creating an MVC project that does have the framework selector. Change it to the version you want, then switch back to creating an Episerver project. Even though you won't have the selector, it will remember the value from the other project type. 

Apr 03, 2018 0:41

No need.

Just create an empty solution and add an episerver project to it.

it picks up v4.6.1 framework automatically.

Apr 03, 2018 8:30

We have now confirmed that a change in Visual Studio 15.6 will cause the target framework to be the same as in the last created project. So a workaround is to e.g. create a class library project that targets .NET Framework 4.61 and then afterwards create an EPiServer project.

We will provide a new version of our visual studio extension with a fix for this as soon as possible,

Apr 03, 2018 13:57

I think there was a misunderstanding with my suggested workaround. You don't have to create a solution or class library project before creating an Episerver project. It's a simple as using the framework selector dropdown for another project type to set the version for the Episerver project. When you do that, Visual Studio sets that as the default value, so you can continue creating just an Episerver project.

No need to create an empty solution or to create a 4.6.1 project beforehand.

@Johan, good to know a new extension is in the works.

Apr 03, 2018 14:40

There is now a new version uploaded to Visual Studio Gallery with a fix for this issue

May 03, 2018 8:54

great success! thx

May 03, 2018 11:54
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.