SaaS CMS has officially launched! Learn more now.

Best practices for language setup

Vote:
 

Hi

I'm looking for what the best practice is for setting up the Language Settings in EPiServer.

Given a page tree that looks like this:

  • Root
    • SiteA root
      • Some content
    • SiteB root
      • Other content

If SiteA should have english and danish and SiteB english and french, how would you set up the lanugages?

What we have done tight now is to assign languages on the "Site* root" pages, and on the top Root, there are no languages. But this seems to give us problems with creating shareable blocks, because they apparently inherit from "Root"?

Would the correct approach be to assign all languages to the top "Root", and then let each site define a narrower language set if needed?

Thank you for any input you have on this.

#195951
Aug 13, 2018 16:33
Vote:
 

I think I may have stumble onto a bug here.

My DEV and QA environments have the exact same setup, but in DEV I was able to create global blocks and translate them. So I went looking in the database.

There I found that on the QA site, there was an entry in tblContentLanguageSettings with fkContentID = 1 and Active = 0.

So to reproduce on DEV, I went to language settings for Root, selected a language and saved. Now I could only create block in that language. Then I went to Root language settings again and removed the checkbox. Now I could not create any blocks.

So the bug seems to be: If Root has no active languages, but has deactivated languages, then you cannot create global blocks. 

Surely this is not intended behaviour?

#195958
Aug 14, 2018 9:42
Vote:
 

Hi Morten, I think you should create a developer support ticket about that - and please share the result here ;-)

#196089
Aug 17, 2018 21:17
Vote:
 

yu, sounds much like a bug to me

#196127
Aug 20, 2018 10:00
Vote:
 

I've created a ticket now, so we will see what they say.

Still I would like to know what the best practice for language settings is, if anyone knows?

#196128
Aug 20, 2018 10:02
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.