Virtual Happy Hour this month, Jun 28, we'll be getting a sneak preview at our soon to launch SaaS CMS!

Try our conversational search powered by Generative AI!

Load Balanced site setting up the various url's

Vote:
 

Hi all

i'm busy setting up a setup like this:

  • Content Delivery server :  www.site.com  (load balanced on 3 servers)
  • Content Authoring server:  cms.site.com  (1 server of the 3 to edit content on)

The content authoring server doubles as a Content Delivery server as well.

I tried to setup something like this but it seems i'm getting some issues with it:

  • When i switch to Editing a page it correctly goes to cms.site.com, but when i leave editing mode and publish the changes, the url sticks to cms.site.com instead of going to  www.site.com
  • An internal hyperlink to another page is incorrectly linked as cms.site.com/page1 in stead of www.site.com/page1 

Is there some specific setting that i need to set to make Episerver behave in a correct way? What i did is change the 'uiUrl' to 'cms.site.com/episerver/cms' in the ApplicationSettings tag in Web.config.

I found a link here: https://world.episerver.com/documentation/developer-guides/CMS/configuration/changing-edit-and-admin-view-urls/

But this refers to relative url within the site, not a different subdomain.

I'm using the latest version of Episerver for my setup.

Any help would be quite welcome!

Kind regards

#221136
Apr 14, 2020 14:05
Vote:
 

I Episerver Admin mode, on the config tab, locate «Manage Websites».

You should have 1 site, with two different hostnames. Make sure www.site.com is marked as Type = Primary and cms.site.com is marked as Type = Edit.

This should hopefully fix both issues.

#221137
Edited, Apr 14, 2020 14:20
Vote:
 

Hi thanks for the quick feedback!

I tried your solution immediately but sadly it did not fix the issues. When i go back from edit mode, back to the published version the url keeps using http://cms.site.com/...... instead of http://www.site.com/......

Anything extra i could setup?

#221138
Apr 14, 2020 14:31
Vote:
 

Did it fix this issue?

An internal hyperlink to another page is incorrectly linked as cms.site.com/page1 in stead of www.site.com/page1 

Exactly how do you «go back from edit mode»?

#221139
Edited, Apr 14, 2020 14:40
Vote:
 

Indeed it did fix the link when i check.

I go back from edit mode by selecting 'view on website' in the option menu after i make changes in Edit-mode. 

#221140
Apr 14, 2020 14:45
Vote:
 

I checked a couple of sites I have worked on, and it works the same way - 'view on website' takes you to the edit URL.
Maybe this is as expected.

#221141
Apr 14, 2020 14:48
Vote:
 

hmmm well the editors on my site don't expect this behavior but expect a 'clean' www.site.com  url. The problem is that links of pages are also incorrectly copied (with cms.site.com) in their newsletters etc. which is confusing.

My plan was to solve this by way of url-rewriting but i wanted to check if Episerver has it's own solution for it.

#221158
Apr 14, 2020 16:39
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.