Try our conversational search powered by Generative AI!

possible bug in read notifications?


I've just updated our solution to the most current via Nuget.

We use the MultiplexingMembershipProvider and MultiplexingRoleProvider for security (intranet solution)

This then uses both the sql and active directory providers.

When a notification tries to be marked as read we get the following error:

500: "Value cannot be null" parameter name: "user"

When I trace this using stackify, it returns one result (for the active directory) user and then 0 results from the sql call (which causes the error) presumably because the user is only an active directory user?

If I turn off multiplexing and just use active directory security, it works. But the solution requires both.

Does anyone have a work around for this?

Apr 20, 2020 22:59

Hi Paul,

For the MultiplexingMembershipProvider and MultiplexingRoleProvider the provider1 must be writable, could you please check settings like below in your web.config.

  • SqlServerMembershipProvider - writable
  • WindowsMembershipProvider - readble 
<add name="MultiplexingMembershipProvider" type="EPiServer.Security.MultiplexingMembershipProvider, EPiServer.Framework.AspNet" provider1="SqlServerMembershipProvider" provider2="WindowsMembershipProvider" />
<add name="MultiplexingRoleProvider" type="EPiServer.Security.MultiplexingRoleProvider, EPiServer.Framework.AspNet" provider1="SqlServerRoleProvider" provider2="WindowsRoleProvider" providerMap1="SqlServerMembershipProvider" providerMap2="WindowsMembershipProvider" />
Apr 21, 2020 3:00

The sql provider is first in the list and appears to be writable as I can add and remove member within the Episerver UI.

For the second provider, I'm use the ActiveDirectoryMembershipProvider.

Any other ideas?

Apr 22, 2020 0:57

Also in what is probably a seperate issue, within the comments section, if you use @<username> whilst making a comment on a page, only the sql users are returned. (when running in multiplexing mode 1=sql 2=activedirectory)

If I run only in ActiveDirectory mode it works.

Edited, Apr 22, 2020 1:04

I can't find a work around for these issues, how do I log an offical bug ?

Apr 23, 2020 3:29

Hi Paul,

Have you tried this?

Add the attribute enableSearchMethods="true" to the <add> tag defining the ActiveDirectoryMembershipProvider in web.config.

Apr 24, 2020 5:11
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.