SaaS CMS has officially launched! Learn more now.

Export/import large content set (full site)

I'm trying to duplicate a full site in the CMS. I can't look at a database copy as this is for creating a new multi-site. The easiest way to do this would be to use the admin export functionality to export the start page including all its sub-pages and files. However, the file turns out to be ~2.4GB and this is an issue for the import process as something on the web server blocks the request:
I've already tried maxing out the maxRequestLength to 2147483647 KB (2TB) and maxAllowedContentLength to 4294967295 bytes (4GB) but still get the same error.
So, getting creative, I tried manually extracting the blob files in the export zip file which reduced the import file to ~40MB and successfully imported all of the site content but with the file binaries missing. I then asked DXP support to manually copy the extracted blob files to the site media container in Azure - I was hoping this would match up the imported files to their binaries in storage. However, support have confirmed they've completed this and images are still not loading 😕
I'm so close to what I need, but stuck at this point and wondering if anyone has advice on the best way to resolve this. I'm keen to try just figure out how to hook up the files after the import without them but haven't thought of an easy way yet.
Dec 13, 2021 7:03

Hi Matthew,

Blob URLs are stored in the tblContentLanguage table. (BlobUri and ThumbnailUri columns).

Use Microsoft Azure Storage Explorer or ask Optimizely support to verify that blobs are copied to the correct location.

Hope this helps!

Dec 16, 2021 20:16

Hi Matthew,

If it is any help this plugin may help with download missing blob files when restoring a site locally.

If you have access to the PaasPortal you can export the databases.

You could also request that Optimizely provide you with a backup of the database and blobs and place them on the integration storage account for you to access.

Is it possible to capture the request using something like fiddler and inspecting for invalid characters?



Edited, Dec 17, 2021 17:29
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.