Try our conversational search powered by Generative AI!

EPiServer commerce setup fails




I am trying to install the EPiServer commerce- when I run the setup .msi file, it comes up with following error


"EPiServer CMS 6.1.370.0 must be installed before you install EPiServer commerce" - Even through episerver6 R2 is installed, and up and running.


Any ideas please.



Jul 17, 2012 15:13

Hi Muhammad,

You may have a mismatched version of CMS installed. The latest version of CMS is 6.1.379.502. If possible, you want to download that version, install that, and attempt to install Commerce again.

Jul 17, 2012 17:41

Hi Richly

I've actually installed the latest version - downloaded today CMS 6 R2 but I guess commerce setup is looking for older version ?

Jul 17, 2012 18:01

Hmm, that's strange. If you have CMS already installed successfully and you've downloaded the latest version of Commerce, then you should not be getting that error. Not sure why the Commerce installer isn't detecting the EPiServer CMS installation. If possible, could you provide screenshots or a screencast of the behavior? You can use a tool such as On what version of Windows do you have CMS installed?

Jul 17, 2012 18:19

CMS is installed on windows 7 and this is where it fails however it works fine for windows server 2008

Jul 18, 2012 12:03

I think I have an idea why the Commerce MSI is not detecting your EPiServer CMS installation on Windows 7. By default, EPiServer CMS installs its files into C:\Program Files and creates a folder called "EPiServer." Did you move that folder to a different location after installation? If so, you will run into that error with the Commerce installer because it looks for the C:\Program Files\EPiServer\CMS\6.1.379.0.

Jul 18, 2012 22:20

File path is all correct. I am running on windows 7 enterprise on MacBook Pro - where windows run as bootcamp . I am not able to install any episerver component which requires episerver to be installed first .

Basically any installer such as composer / commerce fails to identify if EPiServer is already installed . Any ideas please.

Jul 19, 2012 17:32

Have you tried running the MSI installers as Administrator? Right-click on the installers and then run as administrator. There could be some permissions settings in Enterprise that could prevent the installer from detecting the CMS installation when running as a normal user.

Jul 19, 2012 17:43
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.