Vulnerability in EPiServer.Forms

Try our conversational search powered by Generative AI!

Assets upload doesn't work



I'm trying to upload an asset, but nothing happens when I press upload:

If I look in FireBug, I see hundreds of requests (and counting), returning the same result: UploadResult: -1.


Can somebody help me with this problem?



Mar 06, 2013 8:10

Have you configured the storageProviders section baf.config and verified the ecf.asset.config file?

Also i would recommend not using assets as there is no caching whatsoever and the more files you have stored in the asset system the slower it gets because the number of sql calls grows per asset as you put in more and more assets :( Workaround is to write your own virtual path provider for assets and implement proper caching.

Mar 12, 2013 8:20

This is how the storageProviders baf.config looks like:

<storageProvider defaultProvider="DiskBlobStorageProvider">
        <add name="DiskBlobStorageProvider" type=" Mediachase.BusinessFoundation.Blob.DiskBlobStorageProvider,  Mediachase.BusinessFoundation" allowSearch="False" basePath="" />
        <add name="SqlBlobStorageProvider" type=" Mediachase.BusinessFoundation.Blob.SqlBlobStorageProvider,  Mediachase.BusinessFoundation" allowSearch="True" />
        <add name="PublicDiskBlobStorageProvider" type=" Mediachase.BusinessFoundation.Blob.PublicDiskStorageProvider,  Mediachase.BusinessFoundation" allowSearch="False" basePath="" />
        <add name="S3StorageProvider" type="Mediachase.Library.AmazonProviders.S3StorageProvider, Mediachase.Library.AmazonProviders" allowSearch="False" accessKeyID="id" secretAccessKey="secretkey" bucketName="ecf" useSSL="false" useSubDomains="true" expirationTimeSpan="1:0:0" />

The basePath points to an location on a network share.

This is my ecf.asset.config:


<?xml version="1.0"?>
<!-- Auto install flag here will check if Meta Classes are configured during runtime and create them -->
<AssetManagement autoInstall="true">
    <add name="AdminRole" value="Asset Admins" />
    <add name="ManagerRole" value="Asset Managers" />
    <add name="SchemaManagerRole" value="Asset Schema Managers" />
    <add name="ViewerRole" value="Asset Viewers" />
    Setup storage providers:
       providers can be setup based on path, mimeType, size and extension, for example
          <add path="\root\text\*">
            <add extension="txt" mimeType="text/plain" maxSize="1Kb" storageProvider="SqlBlobStorageProvider" downloadProfile="iis"/>
            <add mimeType="image/*" maxSize="200Kb" storageProvider="DiskBlobStorageProvider" downloadProfile="iis"/>
    <add path="\Root\Cloud\*">
      <add storageProvider="S3StorageProvider" downloadProfile="s3" />
    <add path="\Root\Database\*">
      <add storageProvider="SqlBlobStorageProvider" downloadProfile="open" />
    <add path="\*">
      <add storageProvider="PublicDiskBlobStorageProvider" downloadProfile="iis" />
    <add name="thumbnail" type="Mediachase.Commerce.Assets.DownloadFilterThumbnail, Mediachase.Commerce" />
    <add mimeType="image/jpeg" type="Mediachase.Commerce.Assets.ImageFolderElementExtension, Mediachase.Commerce" />

Mar 13, 2013 13:03

Does your application pool indeitity have access to the network share

Apr 11, 2013 5:03

I bed your pardon if you feel it is a a stupid answer, Please check Folders are not read only.

Apr 11, 2013 9:49
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.