SaaS CMS has officially launched! Learn more now.

Adding New Market But Language Not Found In The List

Vote:
 

Hi All,

I am trying to add australian market to our website, followed all the steps enabling the laguage for the new market in CMS but in commerce when I try to add the new market English Australia is not available in the 'Available languages'. Are there any steps I am missing to do to make the language appear in the list?

List of things I did

1) Enabled the language in the CMS admin section.

2) Added the new language to the CMS available languages - works ok.

3) Did the same for catalog in the CMS view and the products and variants can now be seen as if in australian view.

The only missing link is for me to enable the market in the commerce manager with the default language as English australia.

Any advise?

Thanks,
R

#144968
Feb 23, 2016 12:48
Vote:
 

Hi,

The second and third steps should not be required. I just tried myself and when I activate the language in CMS admin, it appears in the list of languages for market right away (of course I need to refresh it).

Can you make sure that Commerce Manager points to correct CMS database. Does it help if you restart the site?

Regards,

/Q

#144974
Feb 23, 2016 13:51
Vote:
 

I have the same issue. I have Russian configured, but it does not appear in the Commerce Manager. DB connections are correct.

Here is my configuration:

And here is how it looks like in the CM:

There is another issue. The market description does not support Cyrillic characters.

That's not good :(

#202950
Apr 04, 2019 13:06
Vote:
 

@Maris: is the remote events working between cms and commerce manager? 

I will file a bug for the limitation on Market description 

#202956
Apr 04, 2019 14:19
Vote:
 

In the meanwhile, you can workaround by editing MarketEditTab.ascx and remove/change the Regex validation. By default it is "^[- \w]*$" , you can change it to be less restrictive, or remove it completely 

#202958
Apr 04, 2019 14:33
Vote:
 

I am not sure regarding remote events. It is in Azure and uses Service Bus as I understand. How can I test if those work?

After CM restart the Russian language appeared.

P.S. Thanks for a Description workaround.

#202959
Apr 04, 2019 14:36
Vote:
 

You can try to make a dummy change in Catalog UI and publish then check if that change is reflected in CM without restarting CM, or vice versa. Commerce Manager only uses CMS API to get enabled languages (ILanguageBranchRepository.ListEnabled()), so there is no magic here. 

#202960
Apr 04, 2019 14:38
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.