SaaS CMS has officially launched! Learn more now.

Synka gruppinformation med LDAp

Vote:
 
Får följande felmeddelande. LDAP_RETCODE=0x31 (LDAP_INVALID_CREDENTIALS) Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. Exception Details: Ldap.LdapException: LDAP_RETCODE=0x31 (LDAP_INVALID_CREDENTIALS) Source Error: An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below. Stack Trace: [LdapException: LDAP_RETCODE=0x31 (LDAP_INVALID_CREDENTIALS)] Ldap.LdapConnection.SimpleBind(String dn, String password) +70 Ldap.LdapConnection.Open() +402 Ldap.LdapConnection.Open(String host, AuthenticationMethod auth, String username, String password, String domain) +68 EPiServer.Admin.SyncGroup.CreateLdapDataSource(String searchFor) +121 EPiServer.Admin.SyncGroup.CreateDataSource() +47 EPiServer.Admin.SyncGroup.Page_Load(Object sender, EventArgs e) +347 System.EventHandler.Invoke(Object sender, EventArgs e) +0 System.Web.UI.Control.OnLoad(EventArgs e) +67 System.Web.UI.Control.LoadRecursive() +35 System.Web.UI.Page.ProcessRequestMain() +736
#12104
Jul 06, 2004 16:45
Vote:
 
Har kollat vidare på det och fått en användare som har admun rättigheter. Får fortfarande samma fel. Jag tror att dom har lagt servern på en annan port med då borde jag ju få felmeddelande server down eller nåt. Vidare så när man kör webben så fåt man upp standard windows login. Finns det når sätt att komma runt detta. Man skall ju inte behöva logga in två gånger på ett intranät.
#13655
Jul 08, 2004 13:04
Vote:
 
Hei. Jeg har akkurat gjort samme implementasjon, bare med redaktører som logger seg på med domene-bruker fra internett-site. Sørg for at brukeren du har satt opp til å logge deg på LDAP med, at denne brukeren har tilstrekkelig rettigheter, som regel har den det. Det andre er at du i brukernavnet også kan prøve å sette domenenavnet foran, f.eks. slik: DOMAINNAME\DomainUser Hvis du får opp slik melding når du prøver å komme inn på siten, har du nok allerede tatt av Anonymous Access på web siten. Når dette skal gjøres med ASP.NET applikasjoner, må du også legge til en setting i web.config, for å impersonere den brukeren som aksesserer sidene. Legg til følgende setting under i web.config-filen: Håper dette kan hjelpe deg litt på vei. Frank :)
#13656
Jul 08, 2004 13:35
Vote:
 
Se forøvrig også følgende faq på dette (lagt ut idag): http://www.episerver.com/templates/faq____6045.aspx
#13657
Jul 08, 2004 13:38
Vote:
 
Har testat. Användaren har rättigheterna som krävs men ldap ligger inte på port 389 utan 390. Håller på att bli vansinnig på detta. Borde ju inte vara några problem. Har gjort allting by the book och ändå kan jag inte synka gruppinformationen. Vilket egentligen innebär att jag inte kommer åt Ldap servern : (. Börjar om igen och skall se om det är nåt som jag missat. Fast det är en sak som jag tänkt på. I machine.Config -> Processmodel är suer satt till system. Kan det vara detta som hindrar att läsa från AD ?????
#13658
Jul 08, 2004 15:55
Vote:
 
Hei. I de tilfellene jeg har vært borti når det gjelder integrasjon mot LDAP og/eller AD, så har det ikke vært noen behov for endringer i machine.config. Sørg for at rootcontext FAKTISK står til det samme som LdapServer i LDAP databasen. I mitt siste tilfelle, så var navnet på rootcontext noe helt annet enn ldapserver-navnet, f.eks. Altså kun 1 ledd i rootcontext, og ikke to, slik som det ofte er. Dette finner du enten ved å "browse" ldap-serveren med et verktøy, enten direkte i AD på domene-serveren, eller via et verktøy, slik som LDP (søk på Google). Frank :)
#13659
Jul 09, 2004 14:56
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.