Files and folders from sharepoint are not showing in filemanager when using Sharepoint connector.

Hi all! I'm trying to get the filesystem part of the sharepoint connector to work properly but the files of my sharepoint site never show up in the filemanager. The sharepoint site shows up but there are no files or folders visible. In admin mode I can set read access for everyone but I still can't see any files or folders. In addition to following the installation guide I've also excluded the spwebservices directory in the sharepoint installation, as described here in an earlier thread. The user that I have configured in the epi web.config has been added as an administrator in the sharepoint site. Does anyone have an idea what I should try?
Mar 23, 2005 9:48
I forgot to mention that the webservices seems to be working. I can call them using the webinterface on the sharepoint server and from the sharepoint connector debug page in edit mode. Cheers, Daniel
Mar 23, 2005 9:50
Daniel, I had a similar issue recently (using EPiServer 4.40), and the problem was down to the fact that the username used to access Sharepoint is the user you log in to EPiServer as - not the user in the web.config, as the documentation seems to say. Do you have a user that is common to both Sharepoint and EPiServer? Regards, Mark
Mar 24, 2005 14:01
Hi Mark! I have a domain admin user that has been added as episerver admin and sharepoint admin. However, when I look into the security log of the SP machine it seems like episerver is providing an incorrect password. I get two failure audits in the security log: Logon attempt by: MICROSOFT_AUTHENTICATION_PACKAGE_V1_0 Logon account: DOMAIN\domain_adm Source Workstation: UGGLA Error Code: 0xC0000064 For more information, see Help and Support Center at followed by: Logon Failure: Reason: Unknown user name or bad password User Name: DOMAIN\domain_adm Domain: Logon Type: 3 Logon Process: NtLmSsp Authentication Package: NTLM Workstation Name: UGGLA Caller User Name: - Caller Domain: - Caller Logon ID: - Caller Process ID: - Transited Services: - Source Network Address: Source Port: 1348 /Daniel
Mar 30, 2005 10:07
Some additional information: As I can see in the code and from the logs, what happens when I try to access the filesystem, the webservice is called twice, first with the user configured in the epi web.config and then impersonated as the user that I'm logged in with. If I set the user in the epi web.config to my domain admin and log in with the same user in episerver, the first call succeeds and the second call fails as in my previous post. Could the problem be related to the type of authentication I use? Basic vs Windows Integrated? Regards, Daniel
Mar 30, 2005 10:53
Daniel, The only way I got this working was to make my SharePoint site have basic authentication ONLY, and to disable anonymous access. (I think this was mentioned in the EPiServer/SharePoint how-to document). Perhaps this should be raised as a bug, as it's potentially insecure. Hope the above helps, Mark. P.S. Have you attempted getting Sharepoint to see EPiServer using the sample web parts provided? I haven't succeeded at all with that.
Mar 30, 2005 16:05
Hi Mark! Our interest has been to use integrated windows authentication on both the sp and the epi site since it is a requirement for our customer's intranet solution. However, out of the box, it seems like the connector is not implemented for that kind of solution. If you search in the source code supplied in the dev directory for the string "EPiServerSP.AuthenticationModule.AuthenticationListner.FindPassword" you'll find some interesting code in these places: SPFileSystem\SPDirectory2004.cs SPFileSystem\SPFile2004.cs SPIntegratedProject\SPUserControlBase.cs At those points the connector implements impersonation by using the authentication module. That module in turn depends on basic authentication in order to extract the user's password in clear text from the httpcontext. If the sp and epi servers and the user's client are all part of an AD domain the preferred method should be to use Windows Integrated authentication and Kerberos delegation as described in this microsoft MSDN article: and in this "the code project" aricle: The quick but very ugly way to make the connector use windows integrated authentication and kerberos delegation/impersonation is to set the webproxy's credentials to the System.Net.CredentialCache.DefaultCredentials in the places above. You also have to enable impersonation in the epi web.config and make sure that users have sufficent rights on both systems. In this project we don't have the requirement to use epi functionality in SP so I haven't done that.
Mar 31, 2005 10:10
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.