EPiServer.SystemPage and the WYSIWYG

Hi, I'm using Episerver's DHTML editor in one of my aspx pages (this aspx is part of our Episerver solution for the client). This aspx page with the WYSIWYG is a popup that is called from edit mode when the user presses a button somewhere on the edit page. Everything worked fine in 4.50, but when upgrading to 4.60 I get an error when calling my popup that contains the DHTML control. The error is "You are not authorized to view this page". This is because of I've replaced "public class TextPopup : System.Web.UI.Page" with "public class TextPopup : EPiServer.SystemPage". Here is the code that I use to display the WYSIWYG editor in the aspx page : EPiServer.Core.PropertyLongString pls; System.Web.UI.WebControls.PlaceHolder phControl; protected override void CreateChildControls() { base.CreateChildControls(); pls = new EPiServer.Core.PropertyLongString(); pls.EditorSettings = EPiServer.SystemControls.EditorOption.All; pls.CreateChildControls("edit", phControl); } Any help would really be appreciated, because I really don't want to use another editor... Thanks, Danie
Apr 11, 2006 17:49
Did you manage to solve this?
Apr 25, 2006 15:48
Hi, not yet. I've contacted Episerver support and got this reply : >>As you can see in the IIS log at the redirect it redirects to the folder instead of the file name. That would >>case a listing of the folder, which causes the error "You are not authorized to view this page". I reckon it's a >>side effect of the new globalization. >>I can't promise that a fix will be avaliable at the time, but it's not impossible. We're looking at a timeframe >>of 2-3 weeks to release a hotfix containing some bug fixes. I can't say if a fix for this bug will be included >>in that hotfix, it will depend on how difficult such a fix is to implement, and how it could effect other things.
Apr 25, 2006 17:40
Ok. I'm asking because I had(have) a similar problem. I have some pages that go into the Edit mode and inherit from SystemPage, they are not "normal" EPiServer pages, but rather plain aspx files (which do use EPiServer functions). I had the same thing, as long as they inherited from SystemPage (or any other episerver page class), I would get that, and if they inherited from system.web.ui.page, it would work fine. What I did as a work-around was moving these files into the /edit folder of the website, which solved the problem. Now I have a rather ugly folder structure, but at least it works... I suppose you could try that.
Apr 27, 2006 9:49
Thanks for the tip, I'll try it out. Will let you know (I'll post it in the thread) when Episerver provides a hotfix.
May 02, 2006 12:48
Hi, Episerver released a hotfix last week that will fix this problem. Kind Regards, Danie
May 08, 2006 14:18
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.