Try our conversational search powered by Generative AI!

Using a SAN for the VPP folders


Hi all

I have a SAN mapped on my web servers for the VPP folders to write to.  I can't get them working due to permission problems. 

If I add the path top the VPP folders using the network path I get this error:

Access to the path '\\\company$\VPP\PageFiles' is denied.
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.UnauthorizedAccessException: Access to the path '\\\company$\VPP\PageFiles' is denied.

I have tried impersonating the ASP.NET identity for a user I have on the SAN but still no joy.

I can map a drive to the SAN on the web server using the user account I have to access the SAN and this works correclty but when I add the mapped drive path to the VPP folder I get this message:

Could not find a part of the path 'Z:\Company\VPP\PageFiles'.

I am fast running out of ideas.  Does anyone have any advice?



Aug 26, 2010 16:56

longshot, but maybe you could try to add the computer-name to the vpp folder security: vpp-folder, properties, security, select object "computers" (default is off) and find your machine with the website, and add it to the list, like COMP123$. Note that this is just an idea :-)


And what happens if you add "Everyone" to the vpp, just as a test?

Aug 27, 2010 9:25

If it works with "Everyone" then I would do a installation with the Deployments center and add the path for the vpp. That way you will get the correct access rights set.

Aug 27, 2010 9:44

Hi guys

Thank you fro your suggestions, much appreciated.

The SAN has everyone permissions and I tried running the site through the deployment wizard.  It creates the VPP folders in the SAN which is a good sign.  When I start the site I get the following error when i use the Native path Provider:

The VirtualPathProvider configured to handle page files must return directories that implement IPageDirectory

Any ideas, I can't find anyone else who has had this error

Cheers, Paul

Aug 27, 2010 13:10

Hi all

In case anyone else has this problem it was the account I was running the application pool under.  I tried to impersonate the identity of the user in the web.config, to that of a user who has access, thinking that was adequate but it wasn't until I changed the account the app pool was running under that it worked correctly.  

Cheers, Paul

Aug 31, 2010 15:40
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.